Thread Rating:
  • 6 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Will not rev over 2750
#1
Hi my berlingo 2.0 hdi 2004 keeps going on to some kind of limp mode
It will not rev over 2750 :brickwall: it will be fine I can dive 100 odd miles then you can sit at lights they go green the car will go slow
Other times I stared it it's already on go slow let it sit there for ten mins and it can clear and run fine then it will just go slow out of now were ! Any body out there had this problem please help
Reply
#2
If it's going into limp mode you ought to be getting the engine light on and therefore there will be fault codes stored in the ECU, which you need to get read for a diagnosis.
Reply
#3
Sorry I get no lights up on dash at all when this happens when it clears it's self it runs fine can be 100 miles could be 2 miles
Reply
#4
Hi & welcome.I can only advise you get it scanned.Confusedalut:
Strawberry flavoured windows  Dodgy
Reply
#5
Hello Basher welcome to the forum mite be egr you would be better off getting it read for fault code's
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#6
Had my car scanned the coad is p1351 I goggled it it said some thing to do with glow plugs / relay but I can not find the relay !!!!!
Reply
#7
Have you looked at the condition of the glow plug themselves? Any idea when they were last replaced?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 30
Next gen berlingo multispace
Last Post: churmy
Yesterday 10:30 PM
» Replies: 0
» Views: 19
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1486
Is anyone buying a new car AFTER April 2017?
Last Post: Jed Clampit
Yesterday 09:25 PM
» Replies: 10
» Views: 174
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 29
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 37
Tyre Change...old on front new on back
Last Post: RocketVANman
Yesterday 08:26 PM
» Replies: 12
» Views: 195
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Yesterday 08:10 PM
» Replies: 8
» Views: 332
Newbie
Last Post: j.ted
Yesterday 08:03 PM
» Replies: 6
» Views: 101
Fuel rail pipe replacement
Last Post: Peter Palmer
Yesterday 04:50 PM
» Replies: 3
» Views: 88

[-]
Recent Visitors
Locations of visitors to this page