Thread Rating:
  • 5 Vote(s) - 2.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Won't Lock
#1
So I just bought a berlingo yesterday (2001 I think) and for some reason the car wont lock. The central locking works fine, it's just as soon as the car locks it unlocks immediately after. I think I've narrowed it down to two possible cause (but I could be completely wrong).
1. The light on the dash that indicates that a door is open is also on. I've tried closing all the doors on the car again and again but there's no change. I think the car won't lock if it thinks one of the doors are open.
2. The lock on the boot door is broken I think. The handle works fine I can close and open it fine, the problem is the key wont turn in it and I really don't want to force it in case I break the key.

Just thought I'd try here first before I have to take it to someone to have a look at because at this stage I'm completely stomped.

Thanks!
Reply
#2
Yes, it's unlocking because one of the doors is registering as open. You could try isolating by in turn disconnecting the door harness connectors at one and then the other front doors (don't try to shut the door with the connector unscrewed!) - the back door is harder because you'll have to remove the inner trim and liner panels to unplug the lock connector.
Reply
#3
Just disconnected each door and it turns out its the front driver's side door that's causing the problem. Thanks for the information. My problem now is fixing it. Is it an easy fix?
Reply
#4
It's probably worn contacts of the switch inside the door lock itself. A Xantia or P406 one will fit if the plug looks the same. If you can borrow a "known good" latch, unplug the harness from the actual one after removing the door card and carefully peeling back the foam shielding, and connect up the trial unit to the plug.

Trick it by flipping the cogs to closed with a screwdriver tip and see if the car now thinks all doors are shut. If so, replace the latch. If not, suspect broken wires in the flexible conduit between door and jamb.
Reply
#5
Thanks a lot! I'll definitely give it a try.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Are Mud Flaps the Answer ?
Last Post: doofer
Today 12:41 PM
» Replies: 10
» Views: 246
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: doofer
Today 09:42 AM
» Replies: 3
» Views: 72
Head Light Bulbs
Last Post: doofer
Today 09:38 AM
» Replies: 35
» Views: 1054
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Bob Southey
Today 07:43 AM
» Replies: 3
» Views: 274
REAR AXCEL
Last Post: ajcommercial
Yesterday 09:36 PM
» Replies: 3
» Views: 94
Odd Issues with Rear Door Sensor
Last Post: dumdum
Yesterday 09:25 PM
» Replies: 1
» Views: 73
display fading (MFD B, not bulb related)
Last Post: sks01773
Yesterday 07:50 PM
» Replies: 42
» Views: 6148
radio code
Last Post: Tomcat3
Yesterday 02:32 PM
» Replies: 3
» Views: 96
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Yesterday 01:31 PM
» Replies: 15
» Views: 6776
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Yesterday 12:13 PM
» Replies: 4
» Views: 261

[-]
Recent Visitors
Locations of visitors to this page