Thread Rating:
  • 8 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
dreaded "airbag light"
#1
Hi all,

I am currently having issues with a 2006 1.9d berlingo with the airbag light on.:brickwall:

these are the codes it has come with using main dealer software:-
1) permanent fault: ECU internal (van interface) Not defined
2) permanent fault: Passenger's airbag deactivation Not defined

The van doesnt have a passenger airbag installed! we have tried to reconfigure the settings but the faults still remain.

Have done a continuity check from BSF to BSI found that one red wire (IA6) with no signal!

can anyone else shed any light on this or i am missing something.

cheers shane
Reply
#2
Take a look at this post Shane, it may help!

http://www.berlingoforum.co.uk/showthread.php?tid=8119
Reply
#3
Have you tried something simple like the connectors under the seats, they used to cause the air bag light to come on on my MK2

Things get pushed under the seats and when the seats move it disturbs the connectors. ( they don't have to be disconnected to be a problem )

Simply turn the car off, reseat all the connectors under each seat and try again.

T1ny
[-] The following 1 user says Thank You to T1NY for this post:
  • shane_evans
Reply
#4
(22-11-2013, 12:28 PM)shane_evans Wrote:  Hi all,

I am currently having issues with a 2006 1.9d berlingo with the airbag light on.:brickwall:

these are the codes it has come with using main dealer software:-
1) permanent fault: ECU internal (van interface) Not defined
2) permanent fault: Passenger's airbag deactivation Not defined

The van doesnt have a passenger airbag installed! we have tried to reconfigure the settings but the faults still remain.

Have done a continuity check from BSF to BSI found that one red wire (IA6) with no signal!

can anyone else shed any light on this or i am missing something.

cheers shane
I would first do what Tiny said, if no joy physically chase the twisted wire pair back from the engine fuse box for signs of damage, it runs down from engine fuse box into side panel, up and across under windscreen wipers(remove grill) and down through bulkhead. I was lucky the white wire of the twisted pair was burnt out just a few inches out from the engine fuse box.
[Image: 2ey7szc.jpg]
[Image: 3010yrt.jpg]
[Image: 2moz57n.jpg]
[Image: 23tgnyo.jpg]

If wires are good I think Rustscrats can guide you further :thumbsup:
[-] The following 1 user says Thank You to mitumatu for this post:
  • shane_evans
Reply
#5
Hi thanks for the replies. :-)
I tried cleaning the connectors which didnt work unfortunately.

I will check the twisted wires :-)
Reply
#6
I had one last week where there was a whole raft of faults. It wasn't until I'd pulled out the BSI and checked every wire for continuity, I realised there was a fuse missing! The owner confessed to tinkering a little before he'd called me in...
[-] The following 2 users say Thank You to addo for this post:
  • Ol'Jeffers, shane_evans
Reply
#7
Sorted cheers for that. Was broken wire on the twisted wires!!

Cheers for the help :-)
[-] The following 1 user says Thank You to shane_evans for this post:
  • addo
Reply
#8
Addo,I'm surprised at a man of your calibre not checking the basics first. I've NEVER been caught out like that.:whistle::whistle:
Strawberry flavoured windows  Dodgy
[-] The following 1 user says Thank You to ron for this post:
  • addo
Reply
#9
I'm afflicted with near terminal honesty.
Reply
#10
I suppose the fuse was near a terminal
Malc

Stupid computer!
Security system should not fail safe!
Security system should fail dangerous!
[-] The following 1 user says Thank You to crickleymal for this post:
  • addo
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
radio code
Last Post: Tomcat3
Today 02:32 PM
» Replies: 3
» Views: 70
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Trevor
Today 02:13 PM
» Replies: 2
» Views: 32
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Today 01:31 PM
» Replies: 15
» Views: 6736
display fading (MFD B, not bulb related)
Last Post: saskak
Today 01:02 PM
» Replies: 41
» Views: 6097
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 12:13 PM
» Replies: 4
» Views: 238
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 12:07 PM
» Replies: 1
» Views: 56
Rear light bulb holders - keeps dropping bulb.
Last Post: Top drive
Today 12:01 PM
» Replies: 7
» Views: 293
What website to pass time over a winters evening...
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 1
» Views: 248
Good Evening to you all.
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 8
» Views: 230
REAR AXCEL
Last Post: Top drive
Today 10:45 AM
» Replies: 2
» Views: 50

[-]
Recent Visitors
Locations of visitors to this page