Thread Rating:
  • 3 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
engine fan stopped working.converted fan to switch but wires overheat!!!
#1
Sad 
I was stuck in Spain as the fan did not come on and we were pushing 35 degrees so checked out fan and it was fine,local garage helped by wiring a switch on the dash for me to carry on home it worked great but the wires even though heavy duty get hot.does not bother me back in the uk as the fan is not needed but going back to Spain soon and wondered if the switch will be OK?
Reply
#2
Did thet fit a HD switch?A sw that is not big enough can heat & cause resistance & overheat.Confusedalut:
Strawberry flavoured windows  Dodgy
[-] The following 1 user says Thank You to ron for this post:
  • raymmas
Reply
#3
As Ron says, make sure the switch is rated to carry the required current.
Somedays you're the pigeon, Somedays you're the statue.
[-] The following 1 user says Thank You to steve valentine for this post:
  • raymmas
Reply
#4
It never crossed my mind about the switch good point ron Confusedalut:
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
[-] The following 1 user says Thank You to Jed Clampit for this post:
  • raymmas
Reply
#5
(17-02-2014, 09:16 PM)Jed Clampit Wrote:  It never crossed my mind about the switch good point ron Confusedalut:

That's why I'm in Monmouth & you're in Gloucester.:whistle::whistle:
Strawberry flavoured windows  Dodgy
[-] The following 1 user says Thank You to ron for this post:
  • raymmas
Reply
#6
How did they wire it up? Idealy it should it switched via a relay rather than connected directly through the switch.

Sent from my GT-P3110 using Tapatalk
Reply
#7
If the wires leading to the fan are getting hot then that has nothing to do with the switch.
Either the wires can't cope with the current drawn by the fan motor or the fan motor is
drawing way too much current. (Partially seized bearing or shorted windings in the motor.)
If the switch was under-rated, only the switch would heat up and would fail in a very short time.
I would check the current drawn by the motor first. You can compare it with the fuse rating on the fan circuit.
Before the garage re-wired it did the fuse on that circuit fail? The fan should turn easily. If there's any undue
physical resistance and it feels 'tight' then it may well be worth having it checked. HTH
The Older I get the Better I Was!  Cool
Reply
#8
Thanks for that,it is wired direct to the switch from the fan.I do remember the first switch they put on only worked for a few seconds then fell to pieces!they put another on then it worked but the switch and the cable got warm.. ?The fans all spin freely.and sound normal when switched on.thanks ray
(17-02-2014, 10:16 PM)stuartinlancashire Wrote:  How did they wire it up? Idealy it should it switched via a relay rather than connected directly through the switch.

Sent from my GT-P3110 using Tapatalk

I can easily replace the switch... could I replace the switch with say one from Halfords in which case what would I ask for
(17-02-2014, 09:47 PM)ron Wrote:  
(17-02-2014, 09:16 PM)Jed Clampit Wrote:  It never crossed my mind about the switch good point ron Confusedalut:

That's why I'm in Monmouth & you're in Gloucester.:whistle::whistle:
Reply
#9
The switch would seem to be fine. If the wires are getting hot then the wires are underrated like Ol Jeffers says. What you need to do if you are going to carry on using the present arrangement is to uprate the wires. Measure the current then go to somewhere like http://uk.rs-online.com/web/c/cables-wir...ted-cable/ and use the current rating there to get an idea of the cross sectional area of the cable you need.

Ideally of course, you need to work out why your fan isn't switching on when the engine gets hot. Maybe the sensor has failed or something.
Malc

Stupid computer!
Security system should not fail safe!
Security system should fail dangerous!
Reply
#10
Which model engine do you have, and is it with or without AC?

I think the fan can draw as much as 5A, so I suggest fitting a relay if the fault can't be found easily.

Here's my post on 1.4i non-AC models:
http://www.berlingoforum.co.uk/showthread.php?tid=8297
There may be something in there that can help you...
[-] The following 1 user says Thank You to Gadgetman for this post:
  • raymmas
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 30
Next gen berlingo multispace
Last Post: churmy
Yesterday 10:30 PM
» Replies: 0
» Views: 19
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1486
Is anyone buying a new car AFTER April 2017?
Last Post: Jed Clampit
Yesterday 09:25 PM
» Replies: 10
» Views: 174
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 29
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 37
Tyre Change...old on front new on back
Last Post: RocketVANman
Yesterday 08:26 PM
» Replies: 12
» Views: 195
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Yesterday 08:10 PM
» Replies: 8
» Views: 332
Newbie
Last Post: j.ted
Yesterday 08:03 PM
» Replies: 6
» Views: 101
Fuel rail pipe replacement
Last Post: Peter Palmer
Yesterday 04:50 PM
» Replies: 3
» Views: 88

[-]
Recent Visitors
Locations of visitors to this page