Thread Rating:
  • 13 Vote(s) - 3.23 Average
  • 1
  • 2
  • 3
  • 4
  • 5
engine management light/electrical problem?
#1
hi got problem again with my 02 1.9d 600
From some time had air bag light on constantly so did ask m8 to have a look with his scanner where is the problem- found driver side seat belt pre- tensioner so I did check brown connection and orange to tensioner -all ok but now- m8 said I can clear that code with my scanner and he did but second after engine management light show up-so he have scanned for that too but there was no error code showing up!!! van works fine, no problems with anything but both lights still on- will sort out that tensioner got one on order-how to sort out that engine light? Did notice that when I will close driver door and open something is going on with all dials- speedo, fuel, all of them they jump up and go down???? do think its some electrical problem as if I disconnect battery with positive and connect again on first start engine light goes off but after some drive-switch off and on again light shows up ????? :brickwall: thanks for looking guys Pav
Reply
#2
If the eml is on, there must be a code for it.

Not all cheap scanners will read every code, so the scanner used may not be capable of reading it.

You need to establish what the fault code is otherwise it's pure guess work.
[-] The following 1 user says Thank You to tucker for this post:
  • woski
Reply
#3
Hi, did you do a proper shut down / start up procedure after playing around with the electrics, if not try it first.
Try unplugging / plugging the connector for the pre tensioner as these are well known for giving false airbag faults. Make sure you disconnect battery first!Confusedillyme:

http://www.bba-reman.com/content.aspx?co...ot_process

:thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
[-] The following 1 user says Thank You to Rustscrat for this post:
  • woski
Reply
#4
(15-07-2012, 08:24 PM)Rustscrat Wrote:  Hi, did you do a proper shut down / start up procedure after playing around with the electrics, if not try it first.
Try unplugging / plugging the connector for the pre tensioner as these are well known for giving false airbag faults. Make sure you disconnect battery first!Confusedillyme:

http://www.bba-reman.com/content.aspx?co...ot_process

:thumbsup:
hi and thx,
can't do restart of bsi- don't have remote key- only master key, engine management light is off now- it was fuel pump supply -anyway done that - air bag still on -diagnostic tool can't connect to airbag ecu ???? strange but other day someone else did found code for airbag- pre tensioner driver side something like open circuit or earth don't know - so did change tensioner with all the plugs- still on ????? thx for input guys
Reply
#5
Don't worry about the remote key bit, leave that bit out.
Give it a try, wot have you got to loose.
Air bag warning will come on with both seat pretensioners, steering wheel air bag and any others you may have, if you have a passenger air bag and you disable it via the switch, if an air bag has discharged the a/bag ecu will need resetting. Also if you have bad comms to the a/bag ecu it will illuminate.
The best way of finding this fault would be to find someone with Lexia diagnostics. There is a few people on this site that have it but if you browse the peugeot forums there is a list somewhere with people offering this service.

Have a read of what happend to mine. http://www.berlingoforum.co.uk/showthread.php?tid=1453
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
(16-07-2012, 09:39 PM)Rustscrat Wrote:  Don't worry about the remote key bit, leave that bit out.
Give it a try, wot have you got to loose.
Air bag warning will come on with both seat pretensioners, steering wheel air bag and any others you may have, if you have a passenger air bag and you disable it via the switch, if an air bag has discharged the a/bag ecu will need resetting. Also if you have bad comms to the a/bag ecu it will illuminate.
The best way of finding this fault would be to find someone with Lexia diagnostics. There is a few people on this site that have it but if you browse the peugeot forums there is a list somewhere with people offering this service.

Have a read of what happend to mine. http://www.berlingoforum.co.uk/showthread.php?tid=1453

hi thx for input,
story goes on had lexia connected to ecu- 3 codes-drivers seatbelt pretensioner -fail, something with air bag ecu - not known and passenger air bag - not know! that last one is strange as in that model there was no passenger air bag- all codes are permanent ,so I done cheks on all connectors, all cables and all is ok we cheked pre tensioners both ok. Notice one thing: when wiggle some cables in main connector to airbag ecu and switch on ignition - air bag light shoes up then goes off and after 2 sec goes back permanently.Read that it is some pre check but not sure.Can you reset air bag ecu? how often it fails? Thanks for looking guys all feedback welcome cheers Pav:brickwall:
Reply
#7
The air bag ecu is underneath the center console. Check the earth points around this.
Do a shut down procedure and disconnect the battery then try unplugging / plugging the orange connector to it as there are bridging pins in this to disable functions that you don't have eg. passenger air bag.
Lexia can reset your ecu but be warned, messing about with air bags or pretensioners with power on could in the worst case fire them off.

Was the ecu fault something like "Data Van A (or B)"?
Really we need to know what lexia read exactly to help you.
Confusedcratch:
2006 2.0hdi 600 with bench seat.  Cool
[-] The following 1 user says Thank You to Rustscrat for this post:
  • woski
Reply
#8
(19-07-2012, 08:14 AM)Rustscrat Wrote:  The air bag ecu is underneath the center console. Check the earth points around this.
Do a shut down procedure and disconnect the battery then try unplugging / plugging the orange connector to it as there are bridging pins in this to disable functions that you don't have eg. passenger air bag.
Lexia can reset your ecu but be warned, messing about with air bags or pretensioners with power on could in the worst case fire them off.

Was the ecu fault something like "Data Van A (or B)"?
Really we need to know what lexia read exactly to help you.
Confusedcratch:

hi problem solved with air bag ecu, memory chip was broken-smoking hot hehe , replace cost £90 all back to normal lol thanks for your input guys Pav
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Head Light Bulbs
Last Post: dargoion
Today 05:52 PM
» Replies: 33
» Views: 977
radio code
Last Post: Tomcat3
Today 02:32 PM
» Replies: 3
» Views: 80
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Trevor
Today 02:13 PM
» Replies: 2
» Views: 38
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Today 01:31 PM
» Replies: 15
» Views: 6739
display fading (MFD B, not bulb related)
Last Post: saskak
Today 01:02 PM
» Replies: 41
» Views: 6100
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 12:13 PM
» Replies: 4
» Views: 243
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 12:07 PM
» Replies: 1
» Views: 60
Rear light bulb holders - keeps dropping bulb.
Last Post: Top drive
Today 12:01 PM
» Replies: 7
» Views: 296
What website to pass time over a winters evening...
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 1
» Views: 253
Good Evening to you all.
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 8
» Views: 233

[-]
Recent Visitors
Locations of visitors to this page