Thread Rating:
  • 4 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
front suspension knock
#1
Knocking noise from offside front suspension - replaced drop links so not them. I can feel movement if I rock the wheel at 12 o'clock, with car on the ground. I think I can feel the movement if I put my hand on the top mount while I'm rocking it with the other so it all points to the top mount worn. Anyone else had similar? Is it a straightforward job? I'm thinking it would make sense to do the shocks at the same time.

2002 mk1 multispace 2.0hdi
[-] The following 1 user says Thank You to dwlawson for this post:
  • Ol'Jeffers
Reply
#2
Welcome!!
The Older I get the Better I Was!  Cool
Reply
#3
Are you sure the bottom ball joint is ok. Had the same as you on mine.
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#4
thanks Griff. Bought two Lemforder wishbones from mister-auto. Looks a reasonably straightforward job. Haynes use a big lever to pop the balljoint out whereas I would have been tempted to reach for the hammer.
Anything to watch out for? Is there a risk the driveshaft pops out while I'm doing this?
Dave
Reply
#5
when i replaced my lower arms the drivers side was easy but the nearsides a bit more fiddly,like you said watch for the driveshaft popping out and puking gearbox oil over your drive!
Reply
#6
I have to admit to resorting to a ball joint splitter to get my n/s one off (2002 1.4 has seperate ball joints)
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#7
Well I replaced the wishbones and no improvement so I decided to replace the top mounts. Bought new shocks as well as it seemed daft to put the old ones back on. Just as well I did as it was the offside shock that was knocking.
[-] The following 3 users say Thank You to dwlawson for this post:
  • CandR, RolyG, taxi
Reply
#8
Glad you got it sorted.
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#9
Just a heads up that I had a similar problem and it turned out to be the drop-links that were worn. Easy enough to remove and check.
[-] The following 1 user says Thank You to davehills for this post:
  • RolyG
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Fuel Guage wrong
Last Post: Solent
Today 07:36 AM
» Replies: 4
» Views: 105
REAR AXCEL
Last Post: polar
Today 06:12 AM
» Replies: 1
» Views: 22
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 16
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 346
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 35
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 45
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 48
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3770
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 214
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 217

[-]
Recent Visitors
Locations of visitors to this page