Thread Rating:
  • 30 Vote(s) - 2.13 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fuse box diagram 200 1.9d van ??
#1
hi all newbie here .... bouhgt a 1.9d van 2000 and had no rev or speedo ... thought it was the usual cluster failure so bought another one ... fitted today but still got same problem...
what i need now and isnt in the hayes manual is an actual picture or diagram of both fuse boxes . i think someones been messing about with them .. ive had a fuse tester on them and some are working and some aint ... i know f2 is for the cluster but i need an actual idiot proof pic or diagram of both to make sure all is where it should be ... any help or advice would be gratefully welcome
Reply
#2
(12-03-2012, 05:30 PM)murray Wrote:  hi all newbie here .... bouhgt a 1.d van and had no rev or speedo ... thought it was the usual cluster failure so bought another one ... fitted today but still got same problem...
what i need now and isnt in the hayes manual is an actual picture or diagram of both fuse boxes . i think someones been messing about with them .. ive had a fuse tester on them and some are working and some aint ... i know f2 is for the cluster but i need an actual idiot proof pic or diagram of both to make sure all is where it should be ... any help or advice would be gratefully welcome

Look in How to /guide section http://www.berlingoforum.co.uk/forumdisplay.php?fid=12

In meantime I have attached PDF file Data:Electrical Equipment from the M49 (Mk1) showing both Fusebox`s / Fuse Identification.

If you are removing fuse`s /connections to test, follow the BSI reset procedure to disconnect the battery. Follow this link:

http://www.bba-reman.com/content.aspx?co...ol_failure

What is working on the instrument cluster ?

Can you provide some more info on your motor
Model
Gearbox type
ABS Yes / No
EPS Yes /No
RPO Number this is a five digit number found on a sticker below the `A` post driver side it might be something like 08900
This helps for wiring diagram identification.




Attached Files
.pdf   Data-Electrical Equipment.pdf (Size: 447.63 KB / Downloads: 389)
2003 Citroën Berlingo 2.0HDi Multispace Desire
[-] The following 3 users say Thank You to BlueBlingo for this post:
  • bros400pgm, elliottb, Rustscrat
Reply
#3
thanks m8 . will have a look and give you all the numbers ...
quick details were bought the van last week ... drives like a dream ...
problems when i bought the van were no heater matrix and cluster problem ... van starts 1st time and drives well , all lights, indicators working fine...
instrument cluster problems are on start up only air bag,oil and handbrake light comes on.
fuel gauge is working but temp gauge,rev and speedo isnt..
full beam indicator and light indicator is on when in use ... also the indicator arrows on cluster not working... none of the other lights eg. glow plug etc is working on the cluster ... fitted new cluster unit today but problem persisting ... also when turning ignition off sometimes the stop light comes on and beeps 3 or 4 times then stops ??? will get back tomorrow with all numbers you need etc.. and thanks for taking the time to reply
Reply
#4
Hi, if the matrix has been removed/replaced then it could be a connection problem.
Check you have a good earth on pins 6 & 3 of the speedo unit connector.
If not check the earth point (MC32).
This is located on the passengers footwell inner wing behind the plastic trim. Worth a check?? :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#5
cheers rustcat ....... been at it again today and cannot get my head round the fusebox may think its from a later model or even a pug
will post pics shortly

anyway the van is a
Berlingo 1.9D 600
variant - MBWJYB
VERSION - M*WJY*

VIN/CHASSIS NO - VF7MBWJYB65626087

here is a pic of fusebox under steering wheel
[img][Image: FUSEBOXBERLINGO.jpg][/img]

and here is one to the right of battery near engine

[Image: ENGINEFUSEBOX.jpg]

:brickwall::brickwall::brickwall:

Reply
#6
found this pic of 1.9d peugoet fuse box


[Image: Phase3fuseboxP.jpg]



says its a phase 3 fusebox .... im totally lost now
Reply
#7
Check fuse 6. :thumbsup:

[Image: 2s6vbxx.png]
2006 2.0hdi 600 with bench seat.  Cool
Reply
#8
doh ... right fuse 6is 5 amp

should i xhange fuses to what the peaugot ones are or keep them as they are ???

Reply
#9
Until you definitely know that the fuses are in the wrong place I would leave them as they are. Confusedtudy:
2006 2.0hdi 600 with bench seat.  Cool
[-] The following 1 user says Thank You to Rustscrat for this post:
  • tonyd24
Reply
#10
Checked fuses today Changed ones that wernt workin and they still didn't light up on the fuse checker. May have to bite the bullet and get it to the garage Can anyone tell me if there are relays or fuses missing from the engine fuse box from the pic a couple of posts up ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Starting issues
Last Post: brajomobil
Today 11:56 AM
» Replies: 1
» Views: 44
2005 Berlingo
Last Post: Andre
Today 11:27 AM
» Replies: 2
» Views: 22
Tyre Change...old on front new on back
Last Post: terryd999
Today 11:03 AM
» Replies: 10
» Views: 112
Newbie
Last Post: Andre
Today 11:03 AM
» Replies: 5
» Views: 71
Insurance cost
Last Post: geoff
Today 10:33 AM
» Replies: 2
» Views: 60
Slow starter (diesel)
Last Post: geoff
Today 10:28 AM
» Replies: 12
» Views: 286
Is anyone buying a new car AFTER April 2017?
Last Post: jj9
Today 10:22 AM
» Replies: 5
» Views: 90
REAR AXCEL
Last Post: V6BOY
Today 09:54 AM
» Replies: 6
» Views: 154
Finally a B9 Haynes Manual
Last Post: Satellitemark
Today 09:17 AM
» Replies: 35
» Views: 2283
Fuel rail pipe replacement
Last Post: Peter Palmer
Yesterday 08:19 PM
» Replies: 2
» Views: 61

[-]
Recent Visitors
Locations of visitors to this page