Thread Rating:
  • 10 Vote(s) - 3.3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
horn not working
#1
I've been reading the posts regarding non working horns, and I still can't work out why the horn only works with the ignition key out. This tells me that the horn wiring isn't just wired directly like the Haynes manual shows, it has to be connected in to the ignition circuit somewhere. Does anyone have a correct wiring diagram showing the interconnections that are in the horn circuit?
Reply
#2
Well, there is always the bumper sticker I saw in Reading once - "Horn broken. Watch for finger" Couldn't resist :wave::wave:
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

[Image: ab197646.gif]
Reply
#3
To be of any assistance to you we will need the model, engine, and year as they all have differences.
Most of the electrics are routed via the BSI and you may want to start with a BSI re-set.
You'll find that a little down this page:
http://www.bba-reman.com/content.aspx?co...ol_failure

It is essential that the procedure is followed to the letter.
Hope this helps. :-)
The Older I get the Better I Was!  Cool
[-] The following 1 user says Thank You to Ol'Jeffers for this post:
  • coatess
Reply
#4
(05-07-2012, 01:24 PM)coatess Wrote:  I've been reading the posts regarding non working horns, and I still can't work out why the horn only works with the ignition key out. This tells me that the horn wiring isn't just wired directly like the Haynes manual shows, it has to be connected in to the ignition circuit somewhere. Does anyone have a correct wiring diagram showing the interconnections that are in the horn circuit?


Think you find that when you remove the key, the steering lock bolt must spring out ready to lock the steering wheel.

I found that this was remaking a lost or poor earth connection, hence making the horn work.

Try this to check. With the key in, try the horn. If it doesn't work, then connect a jump lead or similar to the steering knuckle joint down near the pedals and a known earth (I used the door check strap).

No try the horn, if it works then it an earth problem.

My fix was to use a nice think piece of electrical cable and twist it around the steering shaft/rod under the dash and fix the other end to a good earth under the dash. Ever since this fix its been fine and never had issues with MOT
[-] The following 1 user says Thank You to 800HDI for this post:
  • coatess
Reply
#5
Thanks for your replies, I will try these suggestions.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 10:21 AM
» Replies: 2
» Views: 99
After market cruise control
Last Post: cancunia
Today 10:13 AM
» Replies: 7
» Views: 565
TRAILER WANTED
Last Post: ffrenchie
Today 09:28 AM
» Replies: 2
» Views: 41
brake warning light
Last Post: lenoldboy
Today 09:01 AM
» Replies: 0
» Views: 26
touchscreen firmware version
Last Post: manelux
Today 08:46 AM
» Replies: 2
» Views: 291
Newbie
Last Post: Andre
Today 08:29 AM
» Replies: 4
» Views: 57
Highest milage on a mk3
Last Post: Hora
Today 02:54 AM
» Replies: 51
» Views: 11006
Just to say hi
Last Post: polar
Today 02:29 AM
» Replies: 4
» Views: 88
2005 Berlingo
Last Post: polar
Today 02:27 AM
» Replies: 5
» Views: 74
Are Mud Flaps the Answer ?
Last Post: andylobb
Yesterday 09:51 PM
» Replies: 14
» Views: 431

[-]
Recent Visitors
Locations of visitors to this page