Thread Rating:
  • 2 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
instrument cluster problem
#1
i have a 2000 berlingo 1.9d, The problem with the instrument cluster is that the speedo, mileage(you can see part of the mileage)
and rev counter dosent work atall
The temp gauge,fuel gauge and spedo still work, any ideas what i need to do to remedy or is it a case of new clocks? if so is it just a straight swap with a matching set?
Reply
#2
Hi Danny, if the car is multiplexed it's not always good to do a straight swap. I believe sometimes the systems will add up both the old mileage and new!

If you're lucky and it's early 2000 (say, before April) then it is less likely to be multiplexed and you can simply swap for another diesel dash set.
Reply
#3
Thanks for the reply, iv edited the 1st post as the spedo dose work its the milage and rev hand dosent work!
Reply
#4
In the driver's door opening, there's a small white sticker with three lines on it. What's the first line on the sticker (it will usually be five numbers followed by two letters)?
Reply
#5
The 1st line would be 08642fv, what is these for or what will it tell you?
Reply
#6
The RPO is 08642, this is a multiplexed van. Before 08600 were the easier ones to work on.

It also means your cluster can't be so easily swapped. My warnings about mileage apply to your van...
[-] The following 1 user says Thank You to addo for this post:
  • danny06
Reply
#7
Just my luck then, so what way could i go about it? even if i just got my milage clock working/showing id be happy! my best bet would be to leave it with an auto spark i guess.
Reply
#8
I think if you fit the complete kit from a matching spec car that works, it will be fine. This is the dash, the BSI, the COMM unit, ECU and key chips.
Reply
#9
Hi, have you done the basics? Check all fuses inside & engine bay and try a Bsi reset procedure. :thumbsup:
I'm presuming that you have a digital mileage with only half of the digits showing?

http://www.bba-reman.com/content.aspx?co...ot_process
2006 2.0hdi 600 with bench seat.  Cool
Reply
#10
Tbh no I havent checked the fuses as didn't think it would be them, also wot is a Bsi reset procedure and how do I go about it?

Yes it is digital wit onl bits showing, sometimes more than other times!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
glow plugs
Last Post: z1000pete
Today 10:21 AM
» Replies: 0
» Views: 18
Next gen berlingo multispace
Last Post: churmy
Today 09:42 AM
» Replies: 4
» Views: 81
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 09:10 AM
» Replies: 12
» Views: 222
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Hora
Today 07:04 AM
» Replies: 5
» Views: 153
Fuel rail pipe replacement
Last Post: polar
Today 06:54 AM
» Replies: 4
» Views: 100
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 46
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1567
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 51
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 54
Tyre Change...old on front new on back
Last Post: RocketVANman
Yesterday 08:26 PM
» Replies: 12
» Views: 213

[-]
Recent Visitors
Locations of visitors to this page