Thread Rating:
  • 5 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
no heater light symbol
#1
when starting my van i have no heater light symbol showing. it starts but very lots of smoke until i give it a few revs then it clears. i have fitted new glow plugs and a relay box.. any ideas ?
Reply
#2
Hi devil,

Mine is exactly the same! Except for the lots of smoke! The pre heater light on my 2007 diesel never comes on. In Spain the weather may explain it (its always hot!) but it is common for this to occur in the U.K. too. I submitted a similar question nearly a year ago and the general consensus was 'don't worry about it, mine don't come on either' Not too sure about the smoke though! If it clears after a few seconds generaly no problem. Give it good 'seeing to' down the motorway sometimes helps!

I'm sure others will come back with perspectives of their own!

Regards, El Berlingo Confusedunny:Confusedunny:Confusedunny:
Reply
#3
Smile 
she gets a good seeing to the odd time Cool.

is there a fuse for this light ?
Reply
#4
What colour is the smoke and the glow plug light doesnt come on till around zero celcius i believe
Reply
#5
(25-08-2012, 03:48 PM)BerlingoHDI Wrote:  What colour is the smoke and the glow plug light doesnt come on till around zero celcius i believe

In three DV6's since 2007 Ive only ever seen the glowplug lamp twice- both times at well-sub zero temps
Reply
#6
Correct. Heater only comes on if coolant is zero degrees or below.
And then longer time the colder it is. (Forget the exact temps/times.)
Mine came on 3 times last winter!
Reply
#7
Smoke is white. clears after a few revs
Reply
#8
Hi all, No zero or Arctic temperatures here.... ipso facto...never seen it once!

Regards, El Berlingo
Reply
#9
My light always comes on regardless of the temperature but only for a few seconds even in the coldest of winters....I once had an Isuzu trooper with 125k on the clock when i bought it and the dealer told me not to worry as its only unburnt fuel ( still not sure whether this is correct ) i ran it 2 years and sold it with 165k on it and it did this everyday without once failing me or burning oil.....maybe its the same ?
Reply
#10
I have had white smoke on startup before on another vehicle and it is unburnt fuel as peacey says, my problem was a faulty injector leaking diesel when switched off adn when started again it wouldnt burn properly causing the white smoke. This is what the garage told me anyway and they gave me a bottle of forte diesel cleaner to put in fuel tank which cured it for a few months then it started again , so the garage replaced injector for a second hand part and it was good ever since.

By all means i am not saying this is your problem but it sounds similar.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Supermarket Diesel
Last Post: Top drive
Today 07:36 AM
» Replies: 3
» Views: 29
BULBS!!
Last Post: Jed Clampit
Yesterday 11:05 PM
» Replies: 17
» Views: 565
Finally a B9 Haynes Manual
Last Post: Satellitemark
Yesterday 10:43 PM
» Replies: 39
» Views: 2493
clunking noise
Last Post: Silverberlingo
Yesterday 10:35 PM
» Replies: 4
» Views: 72
TRAILER WANTED
Last Post: Silverberlingo
Yesterday 10:29 PM
» Replies: 4
» Views: 81
longitudinal roof rails
Last Post: Chrisville
Yesterday 10:27 PM
» Replies: 0
» Views: 26
Head Light Bulbs
Last Post: Hughzie
Yesterday 09:23 PM
» Replies: 36
» Views: 1140
Newbie
Last Post: Jed Clampit
Yesterday 08:37 PM
» Replies: 6
» Views: 91
first time ctroen owner
Last Post: Jed Clampit
Yesterday 08:25 PM
» Replies: 1
» Views: 45
M59 Cooling system change PDF
Last Post: coatess
Yesterday 06:46 PM
» Replies: 1
» Views: 214

[-]
Recent Visitors
Locations of visitors to this page