Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
overheating 2.0hdi
#1
My 2.0hdi berlingo has recently started runing a little warmer (weather is warmer than usual)

Temperature yesterday went up to just under the 100deg mark when climbing up hill with little load on board at 30mph.
I parked and was suprised that the cooling fan wasnt running.
I've checked the fuse (hayes says 16 or 17 in the engine fuse box) nothing wrong with that.

Would you expect the cooling fan to have cut in?
The temperature gauge in the cabin normally takes a while to get to 87 and sits there.


Having read a few posts on here could it be linked to my AC no longer cooling? light comes on but no cool air. I had assumed that as the car is 10 years old maybe just needed the ac "re-gassing"
Reply
#2
check your cooling fans are not seized or just not working. Just run some twin from a battery to each fan. They are known to just stop working usually due to lack of use.
Reply
#3
Hi  check this post had similar problem


http://www.berlingoforum.co.uk/thread-11...r#pid76193
Reply
#4
(03-07-2015, 12:29 AM)Dawid Benazi Wrote:  Hi  check this post had similar problem


http://www.berlingoforum.co.uk/thread-11...r#pid76193

Hi David
Thanks for the link. I'll take a look when I get home. Took it to a garage yesterday and they seemed to think it was ok the fan cut in at about 97 yesterday... I'm not convinced as I've towed with this car and it rarely gets to 90 so something is a miss.
The garage did find a leak in the ac radator so that is being replaced and re filled.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 3
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 331
REAR AXCEL
Last Post: ajcommercial
Yesterday 11:57 PM
» Replies: 0
» Views: 6
Fuel Guage wrong
Last Post: ajcommercial
Yesterday 11:46 PM
» Replies: 2
» Views: 94
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 26
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 39
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 39
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3760
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 208
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 207

[-]
Recent Visitors
Locations of visitors to this page