Thread Rating:
  • 12 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
power drain
#1
hi guys....hope you can help?
bought a new alternator and battery as was having a power drain. van would start first turn of key for first 4 days then start to deteriate till drained....so bought the new alternator and battery and after £138 later still having the same issue..
any ideas?

cheers, Dan
Reply
#2
lost on that one does it not all shut off when the bsi powers down after 5 mins
Reply
#3
(25-04-2012, 02:47 PM)muply Wrote:  lost on that one does it not all shut off when the bsi powers down after 5 mins

no, its a complete power drain over a period of time...have checked some of the possible wiring that could be draining it and even the possibility that the terminals on battery were defective but to no avail.
really, this has me stumped!!!...grrr
Reply
#4
Try charging the battery up, remove the battery lead and connect an ammeter in series (don't try to start the vehicle) see how much current is being drawn and start by pulling individual fuses. If the drain suddenly stops when a certain fuse has been removed then this is the probably the circuit where the fault lies....further troubleshoot on that circuit
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
[-] The following 2 users say Thank You to andy-womble for this post:
  • ron, taxi
Reply
#5
(25-04-2012, 04:02 PM)andy-womble Wrote:  Try charging the battery up, remove the battery lead and connect an ammeter in series (don't try to start the vehicle) see how much current is being drawn and start by pulling individual fuses. If the drain suddenly stops when a certain fuse has been removed then this is the probably the circuit where the fault lies....further troubleshoot on that circuit

legend mate, i'll try that...
Reply
#6
Usual suspects are incorrectly installed radio or aftermarket alarms.

When you disconnect the battery it's advisable to follow the correct shut down procedure first. :thumbsup:
The Older I get the Better I Was!  Cool
[-] The following 1 user says Thank You to Ol'Jeffers for this post:
  • fmplumb
Reply
#7
any news
Reply
#8
(26-04-2012, 01:20 PM)OlJeffers Wrote:  Usual suspects are incorrectly installed radio or aftermarket alarms.

When you disconnect the battery it's advisable to follow the correct shut down procedure first. :thumbsup:

tried that mate and unfortunately its nothing to do with any audio or visual equipment
Reply
#9
(26-04-2012, 10:33 PM)fmplumb Wrote:  
(26-04-2012, 01:20 PM)OlJeffers Wrote:  Usual suspects are incorrectly installed radio or aftermarket alarms.

When you disconnect the battery it's advisable to follow the correct shut down procedure first. :thumbsup:

tried that mate and unfortunately its nothing to do with any audio or visual equipment
This could be a fault in charging circuit try testing :
The voltage you getting at battery when idleing compared with ignition off.
The main current reading (Use clamp meter) on main negative lead at battery when idleing.
What vehicle is it can you leave some details Engine type, transmission type body type etc.
Also provide your 5 digit RPO Number (Build Specification)This should be on a sticker below the "A" post drivers side (My RPO number was 09804 For a 53 Plate 2.0 HDi)
With above info I can provide wiring diagrams for charging circuit if you need them or anything else P.M your email address if you need them and I will send them in PDF format ,it will be friday night thou just off to work Sad

Also have a look in how to section there are some files available to download thanks to PK, M49,M59 etc if I remember there is also info in these on charging circuit.
2003 Citroën Berlingo 2.0HDi Multispace Desire
Reply
#10
(26-04-2012, 06:46 PM)muply Wrote:  any news

will be trying first thing sat morning mate...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
What to look for when buying?
Last Post: aneng
Today 01:47 PM
» Replies: 0
» Views: 6
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 10:21 AM
» Replies: 2
» Views: 107
After market cruise control
Last Post: cancunia
Today 10:13 AM
» Replies: 7
» Views: 569
TRAILER WANTED
Last Post: ffrenchie
Today 09:28 AM
» Replies: 2
» Views: 46
brake warning light
Last Post: lenoldboy
Today 09:01 AM
» Replies: 0
» Views: 30
touchscreen firmware version
Last Post: manelux
Today 08:46 AM
» Replies: 2
» Views: 292
Newbie
Last Post: Andre
Today 08:29 AM
» Replies: 4
» Views: 61
Highest milage on a mk3
Last Post: Hora
Today 02:54 AM
» Replies: 51
» Views: 11009
Just to say hi
Last Post: polar
Today 02:29 AM
» Replies: 4
» Views: 89
2005 Berlingo
Last Post: polar
Today 02:27 AM
» Replies: 5
» Views: 74

[-]
Recent Visitors
Locations of visitors to this page