Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
srceen wash pump.
#1
hi folks  the screen wash on my 04  has stopped working i can hear the motor going but no water. im supecting the pump could be blocked. ive a mot due in a couple of weeks so i have to sort it. can you tell me how to get at the pump is it behind the bumper. (hope i dont have to remove it )  thanks.
Reply
#2
Have you tried taking the tube that goes to the washer jets off and blowing back towards the motor ? This may clear a blockage.

Mark
Reply
#3
remove wheel arch liner make sure pump is pumping through pipe if pumping suspect blocked jets, if not replace pump. They freeze you try and use them and snap off impeller.
Reply
#4
Satellitemark yes i tryed that but no go.
polar yes i took off the jets and blew through no blockage in them i tryed the pump with the jet off just the pipe but nownt. so ive just ordered a new pump online . but was wondering how to get to it.
thanks for your replies.
Reply
#5
Polar says it's behind the wheel arch liner, I did the same job on my b9 with a replacement obtained on eBay , it took about 30 mins to do, it will make life easier if you jet wash the arch line before starting work, also stand back as you remove the pump from the tank as the water will flood out !

If it's similar to my b9 the procedure is
Remove wheel
Remove clips and arch liner
Unclip pump electrics
Pull pump from tank
Swap pipes from old pump to the new one.
Reassembly is the reverse of above .

Mark

Sent from my Vodafone Smart ultra 6 using Tapatalk
Reply
#6
thanks for that ill fit it when arrives. ill put up how i got on with it.
Reply
#7
You may find it has a clogged up rubber boot/seal around the pump, kinda like a grommet that fits in the bottle with a rubber sock with small piercings in the end that clog up, often a whip out and clean will allow it to fill again and pump once more, not all have this but it can totally screw your pumps operation up Wink
Reply
#8
as stated it took around 30 min to do.i brought a new pump of ebay £6.66 only differance was the pipes fit the other way around white to black and black to white. thats it then all ready for the mot in couple of weeks.
thanks for your advice lads.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Taking along time to heat up/warm the cabin
Last Post: jj9
Today 09:17 PM
» Replies: 5
» Views: 117
Supermarket Diesel
Last Post: Silverberlingo
Today 08:26 PM
» Replies: 6
» Views: 121
2005 Berlingo
Last Post: len glover
Today 07:23 PM
» Replies: 7
» Views: 118
Next gen berlingo multispace
Last Post: wildoat
Today 06:24 PM
» Replies: 10
» Views: 224
clunky gear change
Last Post: Hora
Today 05:23 PM
» Replies: 1
» Views: 49
Tyre Change...old on front new on back
Last Post: ricc
Today 05:15 PM
» Replies: 13
» Views: 266
Mesh Bulkhead
Last Post: Jelevents
Today 03:13 PM
» Replies: 3
» Views: 79
longitudinal roof rails
Last Post: Corker
Today 02:48 PM
» Replies: 1
» Views: 66
Finally a B9 Haynes Manual
Last Post: Corker
Today 02:38 PM
» Replies: 42
» Views: 2555
Slow starter (diesel)
Last Post: ricc
Today 11:53 AM
» Replies: 15
» Views: 376

[-]
Recent Visitors
Locations of visitors to this page