Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
whirring noise in engine compartment?
#1
hi all,

i have a 2003/4 berlingo 2.0 hdi and a while ago i noticed a whirring noise that occurs after engine is switched off, sounds like a small electric motor or pump and it lasts a few mins before fading.

it continues even if battery disconnected.

i noticed it again today after it wouldn't start after i changed fuel filter.

my berlingo does not have fuel pump in tank as it has the pressure bulb near filter.

any ideas what it is?

thanks.

steve g.
Reply
#2
Huh
You've already posted this
Reply
#3
He put this question in the wrong section ( M49 ) before and has now started a new topic in the correct area in an attempt to get a better response, hopefully.

Anyway, if it happens with the battery disconnected then it cannot be a motor or other such item. In the previous posting I suggested it might be the cooling system depressurising.
Reply
#4
cheers geoff! i hear what you are saying, but it definitely 'wirrs' like something spinning down.

steve.
Reply
#5
As I posted in the other thread also, it would appear to be the brake servo making the noise on my M59. Stops after a few pumps of the pedal.
Reply
#6
Same with mine, I just guessed it was the ecu shutting down' certainly causing no trouble.
Reply
#7
surely the ecu has no moving parts? and it wouldn't continue if battery disconnected?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Fuel Guage wrong
Last Post: Solent
Today 07:36 AM
» Replies: 4
» Views: 105
REAR AXCEL
Last Post: polar
Today 06:12 AM
» Replies: 1
» Views: 22
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 16
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 347
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 36
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 45
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 48
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3770
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 214
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 217

[-]
Recent Visitors
Locations of visitors to this page