Thread Rating:
  • 16 Vote(s) - 2.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
will not start hdi 2.0 2002
#1
Fuel to filter siemens system.appears injectors not triggering but will fire on easy start.

I shoud add that i bought this berlingo mid dec which had a blown turbo which i have replaced.on completing the work.she fired up straight away but only ran for 20secs.trying again ran for 10secs.but since then has refused to fire at all except on a bit of easy start.one strange fault is injector 2 from tbelt cover is constantly buzzing.
Reply
#2
Check the connections from the engine ecu especially the two round ones IC02A & IC02B. check for corrosion etc.

[Image: 2nve00o.png]
2006 2.0hdi 600 with bench seat.  Cool
[-] The following 2 users say Thank You to Rustscrat for this post:
  • Andre, desperatedes
Reply
#3
Have had the 2 round connectors off.no real signs of corrosion.also the 3 connectors to ecu.anyway with ign on injector 2 from tbelt cover buzzes.if i remove fuse 28 in engine bay fusebox it stops buzzing.that fuse does have a live feed ign on.as regards power to the inertia switch the feed in only had 11.5v so i put a fused jumper in from battery.this makes the buzzing stop.but turning the ign you get no glowplug light but with it disconnected you do.have since done cleaned up all earths on flitch and battery to gearbox.
Reply
#4
If you can P/Mail your vin I'll dig out the drawings. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#5
Have sent you vin no.hope you get it as was having trouble sending message.
Reply
#6
Here's your diagram. If only one injector is making the noise try swapping it to another position and see what happens.

[Image: 2eq4ex5.png]
2006 2.0hdi 600 with bench seat.  Cool
[-] The following 1 user says Thank You to Rustscrat for this post:
  • desperatedes
Reply
#7
Going to get it on lexia the weekend and see how we go from there.have been checking for bad wiring in the meantime but no luck.thanks again rustscrat.
Reply
#8
No worries, let us know what you find. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#9
Will definately report back i personally find it really annoying when following a thread with a fault.then people either disappear off the face of the earth or offer no conclusion to thier problem or how they fixed it.
[-] The following 2 users say Thank You to desperatedes for this post:
  • Ol'Jeffers, Rustscrat
Reply
#10
(26-02-2013, 10:03 PM)desperatedes Wrote:  Will definately report back i personally find it really annoying when following a thread with a fault.then people either disappear off the face of the earth or offer no conclusion to thier problem or how they fixed it.

Yep, it's certainly annoying! :S
2006 2.0hdi 600 with bench seat.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Taking along time to heat up/warm the cabin
Last Post: Hora
Today 12:37 PM
» Replies: 0
» Views: 13
Slow starter (diesel)
Last Post: ricc
Today 11:53 AM
» Replies: 15
» Views: 338
Mesh Bulkhead
Last Post: Jelevents
Today 11:37 AM
» Replies: 0
» Views: 15
2005 Berlingo
Last Post: len glover
Today 10:10 AM
» Replies: 6
» Views: 96
Supermarket Diesel
Last Post: polar
Today 09:28 AM
» Replies: 4
» Views: 49
clunking noise
Last Post: ffrenchie
Today 09:26 AM
» Replies: 5
» Views: 86
BULBS!!
Last Post: Jed Clampit
Yesterday 11:05 PM
» Replies: 17
» Views: 602
Finally a B9 Haynes Manual
Last Post: Satellitemark
Yesterday 10:43 PM
» Replies: 39
» Views: 2497
TRAILER WANTED
Last Post: Silverberlingo
Yesterday 10:29 PM
» Replies: 4
» Views: 87
longitudinal roof rails
Last Post: Chrisville
Yesterday 10:27 PM
» Replies: 0
» Views: 30

[-]
Recent Visitors
Locations of visitors to this page