Berlingo Forum

Full Version: No brake assistance
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
This morning on the way to work,  the brake pedal on my 2007 multispace has lost it's  power. It's traveling down further than normal before any braking force is achieved, and it feels quite a hard pedal. Also upon further inspection, the nearside front wheel seems to be doing most of the braking ( disc quite hot) while the rear offside rear wheel is warm and no more, but the other two wheels are stone cold ! Anyone have any ideas what's wrong ???
(16-04-2019, 06:26 PM)Davie0210 Wrote: [ -> ]This morning on the way to work,  the brake pedal on my 2007 multispace has lost it's  power. It's traveling down further than normal before any braking force is achieved, and it feels quite a hard pedal. Also upon further inspection, the nearside front wheel seems to be doing most of the braking ( disc quite hot) while the rear offside rear wheel is warm and no more, but the other two wheels are stone cold ! Anyone have any ideas what's wrong ???

I would check all 4 braking stations for leaks/siezing,lubricating the pads & replacing brake fluid at the same time. Next check the servo & air filter,if it has one.
You have a brake fluid leak. Most likely the rear n/side wheel.

The braking system is split into two circuits , one works the n/side front and the o/side rear and the other works the offside front and n/side rear. This in case of brake fluid loss you still have a limited braking system.