Berlingo Forum
2.0 HDI90 going into limp mode - Printable Version

+- Berlingo Forum (https://www.berlingoforum.com)
+-- Forum: Specific Model Chat, Problems and Faults (https://www.berlingoforum.com/forum-8.html)
+--- Forum: M59 Berlingo (https://www.berlingoforum.com/forum-28.html)
+--- Thread: 2.0 HDI90 going into limp mode (/thread-20027.html)



2.0 HDI90 going into limp mode - yungsoppy - 24-10-2020

Hello all.

I have a 2004 berlingo multispace 90hp HDI. Has 203000km on the clock.
Recently it has put itself into limp mode (won’t go over 2800 revs), after 10 miles EML light came on, so took it into garage for diagnostic. At fault was MAF sensor & EGR. Apologies, I do not know the exact error code. Codes cleared, engine switched off and back on: MAF sensor again coming up as fault. Checked it and indeed the little metal bit inside had corroded away. So put a new MAF sensor on, codes cleared and it ran brilliantly for about 10 miles then went into limp mode again. Back to garage, this time solely EGR coming up on code reader. Had it cleared and again it ran smoothly for a short while. But now back into limp mode with EML light on. 
I find it hard to believe it’s an issue with EGR as the engine runs super smooth, no misfires no stalling at idle no trouble starting up etc. Fuel consumption isn’t excessive at all. 
Car has just been fully serviced: new oil, air, diesel filter.
Any idea what this could be due to? I know error codes can point to other issues... And I really cannot afford to take it into a citroen dealership to get it looked at right now. Kind regards


RE: 2.0 HDI90 going into limp mode - cancunia - 24-10-2020

Welcome to the forum.
EGR faults can be caused by the MAF as both relate to airflow, but without the actual codes it's a bit difficult to tell. For example, on my 2.0, I replaced the EGR vacuum solenoid, only to discover that the problem was the MAF.
Cheapest next steps:
1, Disconnect the MAF & see if it makes a difference.
2, Buy an OBD reader & download the Torque app to get info from it. There are quite a few threads on here about that & about the MAF for further reference.


RE: 2.0 HDI90 going into limp mode - yungsoppy - 24-10-2020

Disconnected the MAF, to no avail.
Have gone away on a family holiday so when I return I shall get my hands on an OBD reader and get back to you.
Thank you very much for your reply!