Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] EGR fault
#1
hi guys

i have a problem with EGR valve, when the egr was connected i would get a intermittent fault that caused the van to loose power for a few seconds but then it would return to normal after a few seconds, then one day when going to start the van it made some weird noises and i had to cut the engine, waited about 5 mins then it started again fine but started juddering on the way home

took the van into a trusted garage and they hooked the egr up to a computer and drove while monitoring what the valve was doing, they said that it looks like the valve was getting confused which may be caused by either a faulty ECU or a faulty ERG cable. unfortunately there unable to take it further and recommended seeing a auto electrician,

they did actually swap the EGR valve but had the exact same problem

anyone encountered a similar problem? could the MAF sensor play a part in this?

thanks for the advice

ps im driving round with EGR unplugged and seems to be ok apart from engine light and another i think unrelated noise from heat sheild

vans a 1.6 1997 berlingo
Reply
#2
Heat shield probably either corroded or bolts nerd tighyening/replacing that's the easy fix!

If your garage can't fix what is a simple egr valve I would recommend using another garage.

What is the code being thrown up by the eml if any?

Can you describe the weird noises?

When did the engine start to lose power, braking , accerlating, coasting, steady speed etc ?
Reply
#3
not sure what the code was, one time i started the van and it started chugging and sounded really rough, if i didn't take the key out i think it would of cut out on its own, with reference to the loss of power it might of been at a steady speed but too intermittent to be sure as would only happen once every couple of days and couldn't force it to to happen. the loss of power only happened for a few seconds, since having the egr unplugged the van has driven like normal
Reply
#4
Hello

I got the same problem. Do you resolve it already?

Best regards
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
gearbox removal
Last Post: Art b
Yesterday 11:47 PM
» Replies: 4
» Views: 512
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:30 PM
» Replies: 559
» Views: 104325
Door light switch - HELP!!!
Last Post: skoyah
Yesterday 08:26 PM
» Replies: 1
» Views: 104
Persistent EML - P0170 P40 - Help / Info needed
Last Post: brodfather11
Yesterday 07:29 PM
» Replies: 2
» Views: 243
Undoing oil sump bolts.?
Last Post: Romahomepete
Yesterday 06:39 PM
» Replies: 9
» Views: 692
reversing mirrors
Last Post: frank
Yesterday 03:36 PM
» Replies: 2
» Views: 479
Highest mileage Berlingos
Last Post: Brico
Yesterday 11:30 AM
» Replies: 30
» Views: 9416
Berlingo sudden lurching and jumping.
Last Post: ffrenchie
Yesterday 09:08 AM
» Replies: 8
» Views: 1259
Big miles on an auto!??
Last Post: manovilla
Yesterday 07:26 AM
» Replies: 23
» Views: 3593
New Vauxhall (Berlingo)
Last Post: manovilla
Yesterday 07:20 AM
» Replies: 11
» Views: 1295

[-]
Recent Visitors
Locations of visitors to this page