Thread Rating:
  • 3 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Glow plugs Question
#1
!.9D DW8, 2002

Just removed old glow plugs which were burned out, and replaced with a new set. used my mutlimeter to determine this and a seperate battery test.

I was having cold starting problems for a few weeks and got worse to a point where cold starting was impossible.
after replacing with a new set it starts good again so i decided to test the voltage and to see when it cuts out,, full 12 volts and about 40 seconds later it cut out. but while i left engine running idle 2 minutes later 12 volts cut back in and stayed there for 4 minutes till i stopped the engine...
my question is this,,, 1, is this normal and 2, if its not normal would it have burned out my old glow plugs,, should i consider an internal push switch where i can control the preheating or just leave it alone,,, tnx from ireland,,,joe
Reply
#2
just tested my berlingo again and it looks like the glow plugs come back on after 2 minutes and stays on on the time,,, is it normal
Reply
#3
I've only ever had it where they come on for a fraction of a second and then go off, and they only do that when it is very cold.
2010 (B9) Berlingo Multispace XTR HDi 112 - Kyanos Blue
Previously - 2002 (M49) Berlingo Multispace 2.0 HDi Diesel - Arctic Steel
Reply
#4
No its not normal, and yes it will eventually burn out the plugs. If cold they should come on when starting , and go off after running for a little while. (Post and Pre heating ). There is a relay that controls it somewhere under the battery (I think) which is controlled by the temp sensor which decides if the heating and post heating is necessary and for how long.
[-] The following 2 users say Thank You to brodfather11 for this post:
  • joemc20, ron
Reply
#5
tnx guys,, any idea where the temp sensor is located so i can test it.
Reply
#6
the sensor is fitted on the thermostat casing and has a green connector
[-] The following 1 user says Thank You to brodfather11 for this post:
  • joemc20
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Injector/Cam Larder Studs 1.6 HDI
Last Post: saskak
Today 01:07 PM
» Replies: 52
» Views: 8217
Engine noise
Last Post: cancunia
Yesterday 10:03 AM
» Replies: 21
» Views: 5342
clutch pedal
Last Post: ffrenchie
20-02-2019 08:06 AM
» Replies: 9
» Views: 2258
tensioner pulley
Last Post: RJBingham
17-02-2019 07:18 PM
» Replies: 19
» Views: 4034
Eberspacher or similar
Last Post: David Edwards
15-02-2019 01:10 PM
» Replies: 13
» Views: 3953
Overheat and antipollution?
Last Post: mikeB
15-02-2019 11:39 AM
» Replies: 26
» Views: 7341
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
14-02-2019 10:04 PM
» Replies: 651
» Views: 136927
Valves DW8
Last Post: Arbe
13-02-2019 11:11 AM
» Replies: 51
» Views: 11356
throttle cable - where to get a good one.
Last Post: Arbe
12-02-2019 05:35 PM
» Replies: 9
» Views: 2761
2003 2.0 HDI Poor fuel consumption
Last Post: ffrenchie
12-02-2019 04:23 PM
» Replies: 31
» Views: 8181

[-]
Recent Visitors
Locations of visitors to this page