Thread Rating:
  • 3 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Knock knock
#1
Hi All,

Just bought an 05 1.9d with 109000 on the clock.

Has had recent timing belt, sump and exhaust.

Was running fine for a week then the other day it started knocking and the engine warning light came on....

When I start the engine it knocks for a bit then clears. Followed shortly by the Engine light coming on. The engine idles smoothly.

Try and pull away and I have to over rev it to stop it from stalling. It also does a big puff of smoke and spat out some black water via exhaust.

There is also a bit of oil? Sitting on top of the manifold at the rear of the head. (I'm assuming rocker cover gasket)

I took it to my local garage and the guy says he can't get it to communicate with the diagnostic kit so I'll have to contact an auto electrician (sounds pricey)

So I guess I'm looking for a steer in the right direction. What to go for first.

Solenoid?

EGR?  

ECU?

Beer?

Thanks in advance.

LB
Reply
#2
Get the timing checked. I bet its also slower than sin. Topping out at about 60 on the flat and struggling to pull its own weight up hills?

Your local garage will have a snap on modus which wont connect to the injection system on this engine, get your self a u480

My injection pump was out of sync (retarded) after a cam belt change ,symptoms were major knock on start up , white smoke , lack of power. Now it pulls like a train ( for a dw8 - i have 2 of them now)

I expect a p0170 code.

How ever i think you also have other issues that im not sure on but getting a u480 and seeing what codes you get would be a start.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Replacement TPS Sensor
Last Post: Jamespworth
Yesterday 07:38 PM
» Replies: 0
» Views: 128
Juddering when pulling away
Last Post: cancunia
Yesterday 07:07 PM
» Replies: 10
» Views: 1109
Hello new member and warning light issues.
Last Post: Jamespworth
Yesterday 07:06 PM
» Replies: 7
» Views: 672
Aux cord functionality
Last Post: mistervanman
Yesterday 06:35 PM
» Replies: 2
» Views: 124
B9 Head Unit Upgrade
Last Post: manuk
Yesterday 06:18 PM
» Replies: 0
» Views: 117
Driver door lock problem help!!
Last Post: ffrenchie
Yesterday 07:42 AM
» Replies: 1
» Views: 396
Can i get away with 205/70r15
Last Post: geoff
20-04-2019 11:38 PM
» Replies: 7
» Views: 1338
How I installed an oil catch can in the 1.6HDi
Last Post: saskak
20-04-2019 09:59 PM
» Replies: 3
» Views: 713
Eco-mode behaviour . . . .
Last Post: Lighty
20-04-2019 09:46 PM
» Replies: 6
» Views: 651
Witter PG46C Towbar 2008 on
Last Post: Jakejjt
20-04-2019 08:28 PM
» Replies: 0
» Views: 266

[-]
Recent Visitors
Locations of visitors to this page