Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dead Battery?
#1
Hi All,

I was just about to go off in my Mk 1 Berlingo 1.9D, turned the ignition key, all usual lights came on, turned key to starting position........nothing except a rapid clicking/chattering sound from the dash. Tried again, this time only oil light came on at 1st position followed by same clicking sound at starting position. Tried a few more times with same results.

Anybody got any ideas? Is it simply a discharged/dead battery or could it be BSI related? It's been raining a fair bit so just wondering about damp somewhere but I only drove it 4 hours earlier and it was totally fine.

Thanks
Reply
#2
First thing I'd check would be the battery. What's the voltage across the terminals? Can you get a charger on it or get a jump from friend or ac? When it's running after a jump then check voltage across terminals to see if the alternator is charging.
Reply
#3
Sounds like a dead battery,

So its either faulty battery, faulty alternator or you left something on and drained your battery.
Reply
#4
Hi Pablo,
Make sure EVERYTHING elctrical is turned off before trying to start it.
Check voltage with engine off
12v = discharged 20% or less
12.3 v = 50% charged
12.7% = 100% charged
When the engine is running the voltage should be around 14 volts if alternator is charging.
HTH,
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#5
Check the earth lead and engine to body earth, they can cause similar problems. Put the headlights on and then try the starter and the lights will dim if the battery is dead.
So where does this bit go then ?
Reply
#6
 It looks as though it is the battery. Reading across terminals is 11.7 volts so I'll try charging it and see if it holds the charge. Will check earthing too.

Thanks for your advice guys!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
tensioner pulley
Last Post: RJBingham
Today 07:18 PM
» Replies: 19
» Views: 2482
Eberspacher or similar
Last Post: David Edwards
15-02-2019 01:10 PM
» Replies: 13
» Views: 3339
Overheat and antipollution?
Last Post: mikeB
15-02-2019 11:39 AM
» Replies: 26
» Views: 6451
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
14-02-2019 10:04 PM
» Replies: 651
» Views: 135649
clutch pedal
Last Post: gissa
14-02-2019 12:43 PM
» Replies: 8
» Views: 1816
Engine noise
Last Post: cancunia
13-02-2019 12:40 PM
» Replies: 16
» Views: 3083
Valves DW8
Last Post: Arbe
13-02-2019 11:11 AM
» Replies: 51
» Views: 10546
throttle cable - where to get a good one.
Last Post: Arbe
12-02-2019 05:35 PM
» Replies: 9
» Views: 2696
2003 2.0 HDI Poor fuel consumption
Last Post: ffrenchie
12-02-2019 04:23 PM
» Replies: 31
» Views: 7993
New Berlingo Anyone????
Last Post: Tree
11-02-2019 11:13 AM
» Replies: 13
» Views: 4461

[-]
Recent Visitors
Locations of visitors to this page