Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windshield leak..
#1
I have read a couple of threads on this subject but not with this particular case.

I noticed a bit of moist under the carpets on the passenger side, but I just discarded as that, moist.
Never the less, it stuck to mind (also I heard few stories that started similarly)

Now it has been pouring rain for a week and now I think I can see where the leak is coming from, if I look from the inside seems to be where the two sheets of metal (roof and pillar(?)) and the windshield meet. the roof lining behind the plastic pillar cover is damped (only a small section) and I could see that it would run down with the door seals (in the inside) down to the footwell. I don´t think is a big leak cause it not that much but still I´d like to fix it.
Question is; can i diy it or need pro?
what kind of glue, cement, liquid, pad, do I use, and if somebody can gimme tips, greatly appreciate it.
thanks
1999 Berlingo 1.8i
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Not another Aircon thread
Last Post: Peter Palmer
Today 02:54 PM
» Replies: 2
» Views: 17
Towing weight
Last Post: Gadgetman
Today 02:51 PM
» Replies: 13
» Views: 2535
random hesitation (increasing frequency) and ESP...
Last Post: Bootlebarth
Today 11:17 AM
» Replies: 0
» Views: 52
battery drains overnight
Last Post: Art b
Today 11:06 AM
» Replies: 20
» Views: 4288
hello all
Last Post: Gadgetman
Today 05:36 AM
» Replies: 7
» Views: 639
A heads up for anyone with rust
Last Post: ron
Yesterday 08:23 PM
» Replies: 2
» Views: 357
How I remove the side trim panels inside the boo...
Last Post: cancunia
Yesterday 07:06 PM
» Replies: 8
» Views: 4768
under engine cover fabrication and repairs
Last Post: berreke
Yesterday 04:40 PM
» Replies: 4
» Views: 644
Front wipers not working
Last Post: Tomcat3
Yesterday 01:50 PM
» Replies: 2
» Views: 262
Weird fan like noise from engine on 1.6 Blue HDi...
Last Post: kingy1912
Yesterday 01:43 PM
» Replies: 0
» Views: 237

[-]
Recent Visitors
Locations of visitors to this page