Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
window washers .
#1
Hi again , . We had a hard frost last week and the screen washer had frozen 50/50 mix .When I tried to operate the washers nothing worked . and only tried working washers at long intervals ,but no joy . Could I have done something to cause the problem . Water in tank is now thawed , when I lift the bonnet drips can be seen dripping from jets . Thanks for any info .  Car is 18 month old XTR auto 1600 . HB
Reply
#2
You can damage the washer pump the impeller can break off, you will still hear it trying to pump but it will have a higher pitch sound. You may also get a slight dribble from the washer jets.

Are you sure the washer pipework is also thawed?
Reply
#3
Positive the water is thawed , there is no noise from the pump at all ....HB
Reply
#4
Ok sound like you have just blown a fuse.
[-] The following 1 user says Thank You to polar for this post:
  • ron
Reply
#5
Yes i would go with the fuse being blown
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#6
Yes there is a 10 amp (red)fuse in the underbonnet box, can't remember the exact number .
Reply
#7
Sorry to ask , but where is the fuse box located ,what does it look like?
Reply
#8
(25-01-2015, 09:07 PM)henry sb Wrote:  Sorry to ask , but where is the fuse box located ,what does it look like?

It's under the bonnet on the right hand side by the battery under a black plastic cover  Smile you will find it in the Citroen hand book if you got one with the car that is 
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#9
Update , took it to the dealer and they replaced it with a 15amp fuse . Everything OK now . But I think the jets are clogged up as they are not pointing on to the screen Have tried sticking pin in nozzle but just makes thing worse , I,ve only tried the passengers side . I see in another post that they can get gummed up .
Reply
#10
(29-01-2015, 04:34 PM)henry sb Wrote:  Update , took it to the dealer and they replaced it with a 15amp fuse . Everything OK now . But I think the jets are clogged up as they are not pointing on to the screen Have tried sticking pin in nozzle but just makes thing worse , I,ve only tried the passengers side . I see in another post that they can get gummed up .

That's what happen's when you just put water in and no screen wash 
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
New Berlingo Anyone????
Last Post: msw109
Yesterday 09:54 PM
» Replies: 5
» Views: 605
multispace headliner
Last Post: big_chris88
Yesterday 09:46 PM
» Replies: 0
» Views: 68
Torsion bar
Last Post: jj9
Yesterday 09:17 PM
» Replies: 11
» Views: 547
Berlingo----- Console
Last Post: Satellitemark
Yesterday 08:53 PM
» Replies: 5
» Views: 760
Partner 3 seat (front) conversion
Last Post: dumdum
Yesterday 08:33 PM
» Replies: 0
» Views: 85
How did the Berlingo get it's name ?
Last Post: Egg on Leggs
Yesterday 07:07 PM
» Replies: 15
» Views: 2998
Tyres and suspension
Last Post: labeline
Yesterday 04:35 PM
» Replies: 11
» Views: 1021
Aftermarket stereo wiring
Last Post: cancunia
Yesterday 01:37 PM
» Replies: 1
» Views: 175
2007 1.6hdi desire
Last Post: Rob.nixon
Yesterday 10:32 AM
» Replies: 4
» Views: 431
Seats
Last Post: kbracingdk
19-01-2019 08:57 PM
» Replies: 0
» Views: 325

[-]
Recent Visitors
Locations of visitors to this page