Thread Rating:
  • 10 Vote(s) - 3.8 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Temp Gauge and Fan
#1
Hi All,

Iv got a 1999 T Reg 600lx. The temp gauge stopped working the other day, the needle sits just below the bottom bar and moves about 2mm when its been running for 10mins. A little investigation and i believe its the temp switch as i noticed the fan didn't kick in after 15mins of running.

Took the plug off the switch and bridges the pins and the temp gauge shot up to max (which is what I hoped) and the fan worked.

Ok but here is my problem, i went to Euro Parts to get the new switch but they didn't stock the part as standard and said it would be a special order and take 5days. So then went to Camberely Autos and they said the same thing?!?!? Very strange for a temp sensor. So finally went to a Citroen dealer and they said according to there system they had never sold one before in all the branches. So I asked the guy why so rare and as my Van has AirCon he said they hardly made any of the Mk1's with AirCon (is this true?).

He said he could order the part from France but again would take 5days and cost £45+Vat...

So my question is has anyone had the same problem? Where can I get the part that might be in stock. The Part No is 133887 and its a temp sensor with 4 pins and a blue top. Hours of Googling hasn't worked..

Thank You

Steve

Reply
#2
I use this suppler and they are very reliable in my experience. Did a search on your part number.

Tom
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#3
sounds like the temp gauge is ok.perhaps its the thermastat thats stuck open so its not getting warm and the gauge is telling you this.
thermostat
Reply
#4
Managed to get the Temp Sensor from All Parts in Croydon and was £30. Changed this evening and sorted the problem out :-)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
egs box
Last Post: billym
Yesterday 11:29 PM
» Replies: 14
» Views: 1070
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 09:57 PM
» Replies: 393
» Views: 57186
where did they go ?
Last Post: brodfather11
Yesterday 09:54 PM
» Replies: 5
» Views: 257
New to site
Last Post: Tomcat3
Yesterday 06:11 PM
» Replies: 2
» Views: 169
1.6 hdi lumpy cold start - SOLVED!
Last Post: Zion
Yesterday 11:43 AM
» Replies: 98
» Views: 15888
[SOLVED] Non-starting 1.6 HDI, now starts but EM...
Last Post: Mankee
Yesterday 10:41 AM
» Replies: 5
» Views: 601
ABS
Last Post: gazthelad
21-07-2018 05:45 PM
» Replies: 6
» Views: 1167
DIY Berlingo Day Van/Occasional Camper System [P...
Last Post: leftfootleashed
21-07-2018 11:20 AM
» Replies: 5
» Views: 816
Hands free radio
Last Post: Jakejjt
20-07-2018 10:03 PM
» Replies: 1
» Views: 519
Beacons and worklights
Last Post: Jakejjt
20-07-2018 09:42 PM
» Replies: 7
» Views: 1134

[-]
Recent Visitors
Locations of visitors to this page