Thread Rating:
  • 13 Vote(s) - 2.92 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine Change Issue
#1
Hi all, after some more help,

I own a 55 2005 plate Berlingo with the dw8 1.9l unit. the engine went bang in it about 3 months ago. Ive replaced the engine with a dw8 engine from a 1999 Mk1 berlingo.

The question is this, I left the ECU from the 2005 engine in the van, im having real issues starting the van, i replaced the cool and temp sensor, i did make it a bit better and it does start, but seems to be overfuelling, white dieselly smoke.

would i need to fit a 1999 ECU to match the new engine in the van. could this solve my issue ?

really tearing my hair out now

Cheers Tom
Reply
#2
Check on engine from M49:
1. Timing.
2. Presence of oil in the cooling system and reverse.

For more help we need vin of donor - M49 and your M59.
Reply
#3
All timing present and correct, we have also installed a new lucas fuel pump, so all the timing was set then, as far as im aware no oil in the coolant, when checked old coolant water was an orangey colour. forgive me for sounding dull, but im no expert.

so im guessing the ECU would not affect running then. my local garage sourced the engine so im not sure how i would locate the vin of the donor m49.

thank you Tom
Reply
#4
One more time:
we need a VINs of both Berlingo.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Disc pads.
Last Post: dunc391
Today 10:56 PM
» Replies: 2
» Views: 142
Forum newb slightly cheating...
Last Post: Gadgetman
Today 10:09 PM
» Replies: 3
» Views: 195
Front seat and trim around handbrake and gear kn...
Last Post: Gadgetman
Today 09:55 PM
» Replies: 1
» Views: 148
Bypassed shunt fuse problem
Last Post: Gadgetman
Today 09:33 PM
» Replies: 2
» Views: 201
Seat Belt
Last Post: V6BOY
Today 07:58 AM
» Replies: 0
» Views: 124
Engine Fault Light On With On Screen Warning Aft...
Last Post: Luis Rosa
Today 05:00 AM
» Replies: 30
» Views: 3071
new mot
Last Post: Oi69
Yesterday 09:56 PM
» Replies: 9
» Views: 945
Dingo - 05 - 2.0 HDI
Last Post: jj9
Yesterday 09:53 PM
» Replies: 63
» Views: 11552
Rear door
Last Post: Gravity
Yesterday 07:28 PM
» Replies: 3
» Views: 576
Cruise control (again), yes again, but working (...
Last Post: Collapsedsuspension
Yesterday 10:09 AM
» Replies: 96
» Views: 7543

[-]
Recent Visitors
Locations of visitors to this page