Thread Rating:
  • 10 Vote(s) - 3.7 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fanbelt / pas pump problem
#1
another problem !!!!!! the fan belt was not running flush with the big cog at the top and wearing, i got my mechanic mate over and he said hed change the belt, everytime he starts the engine the belt jumps off?? hes stripped it down and the power steering pump wheel is not aligning with the others apparently, there are 3 bolts holding this pump into the frame, the botton one was snapped off inside, im hoping this is why its not running in line ?? anyhow im now torn between trying to get the bolt removed or buying a new pump and am not entirely sure if this is the actual problem >> <<?? was wondering if this is common or has anyone else encountered this ??, thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
So long and thank's for all the fish!
Last Post: brodfather11
Today 04:30 PM
» Replies: 1
» Views: 41
newbie here
Last Post: Mackem3
Today 09:49 AM
» Replies: 0
» Views: 25
Non start , turns over
Last Post: Multispacer
Yesterday 12:20 PM
» Replies: 1
» Views: 85
Looking for breakers with Petrol M59
Last Post: Multispacer
Yesterday 10:29 AM
» Replies: 1
» Views: 69
MyCitroen App
Last Post: Blakey
Yesterday 08:01 AM
» Replies: 8
» Views: 432
Whats the S for? 19oC/19oC S
Last Post: Hughzie
26-05-2024 04:33 PM
» Replies: 2
» Views: 137
What does a service consist of ?
Last Post: StarFish
26-05-2024 01:46 PM
» Replies: 2
» Views: 105
Ad blue use age
Last Post: curlywurly1971
26-05-2024 08:46 AM
» Replies: 0
» Views: 79
Air con re gas
Last Post: shtu
25-05-2024 06:24 PM
» Replies: 1
» Views: 80
Free undertray for 2011 multispace
Last Post: needsmust
25-05-2024 10:44 AM
» Replies: 0
» Views: 46

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK