Thread Rating:
  • 32 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Loss of power
#1
Engine loosing power and a vibration Berlingo going into dealer tomorrow, maybe an injector?!
Car has done 17k.
I DO MISS MY BERLINGO Heart
Reply
#2
Did you see any fuel leakages under bonnet?
Reply
#3
Hi PK, no havnt seen any.
I DO MISS MY BERLINGO Heart
Reply
#4
Ok got car back from dealer and they could not find a problem with a road test or on the machine, they did say maybe it has to develop into a bigger problem or until a warning light comes on.
I DO MISS MY BERLINGO Heart
Reply
#5
(16-09-2011, 09:03 AM)philip Wrote:  Ok got car back from dealer and they could not find a problem with a road test or on the machine, they did say maybe it has to develop into a bigger problem or until a warning light comes on.
How's the car now ?- I hope the blingo's loss of power problems disappeared
Former 2011 Mk3 XTR owner Confusedalut:
Reply
#6
Nope still loosing power from time to time.


Sent from my iPhone using Tapatalk
I DO MISS MY BERLINGO Heart
Reply
#7
Hi Philip.
Try to change petrol station.
Reply
#8
DAft reply, TBH but when you are moving, and its safe to try this, press the footbrake slightly together with the Accel pedal, and see if you loose power, I believe that when you press the foot brake it slightly kills power to the engine, had this problem on an 53 plate Xara Pic exclusive (cruise control fitted) there was 2x micro switches on the pedal on that model., just for your info as that was my problem a few years back..
Reply
#9
(18-11-2011, 09:06 PM)pk7478 Wrote:  Hi Philip.
Try to change petrol station.
Hmmm never thought of that one, i do normally use either Esso or Morrisons.


(18-11-2011, 10:27 PM)digger Wrote:  DAft reply, TBH but when you are moving, and its safe to try this, press the footbrake slightly together with the Accel pedal, and see if you loose power, I believe that when you press the foot brake it slightly kills power to the engine, had this problem on an 53 plate Xara Pic exclusive (cruise control fitted) there was 2x micro switches on the pedal on that model., just for your info as that was my problem a few years back..
Im not going to know if it looses power because of the micro switches or because i have braked Confusedcratch:

I DO MISS MY BERLINGO Heart
Reply
#10
(19-11-2011, 07:20 AM)philip Wrote:  
(18-11-2011, 09:06 PM)pk7478 Wrote:  Hi Philip.
Try to change petrol station.
Hmmm never thought of that one, i do normally use either Esso or Morrisons.

In fact it's a good idea. Several years ago when I used a petrol from BP, i was tire to replace spark plugs every 3000-4000 km. After changing a petrol station everything become ok.

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Factory Bluetooth visual identification
Last Post: PAULRYAN52
Today 09:45 AM
» Replies: 4
» Views: 193
2004 gearbox removal difficulty...
Last Post: Art b
Today 08:53 AM
» Replies: 12
» Views: 1359
" Free " MOT at Halfords!
Last Post: cancunia
Today 07:32 AM
» Replies: 8
» Views: 1204
Berlingo WAV
Last Post: KeithPet
Yesterday 09:30 PM
» Replies: 2
» Views: 340
Newbie - hello
Last Post: Portugeezer
Yesterday 09:29 PM
» Replies: 3
» Views: 625
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:56 PM
» Replies: 483
» Views: 80410
Under seat storage trays
Last Post: hawaiianblue
Yesterday 08:29 PM
» Replies: 1
» Views: 533
Vacuum oil change & magnetic sump plug
Last Post: brodfather11
Yesterday 06:48 PM
» Replies: 9
» Views: 937
Big miles on an auto!??
Last Post: Tree
Yesterday 03:44 PM
» Replies: 17
» Views: 897
2018 Berlingo....
Last Post: Tree
Yesterday 01:46 PM
» Replies: 12
» Views: 2509

[-]
Recent Visitors
Locations of visitors to this page