Thread Rating:
  • 32 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Loss of power
#1
Engine loosing power and a vibration Berlingo going into dealer tomorrow, maybe an injector?!
Car has done 17k.
I DO MISS MY BERLINGO Heart
Reply
#2
Did you see any fuel leakages under bonnet?
Reply
#3
Hi PK, no havnt seen any.
I DO MISS MY BERLINGO Heart
Reply
#4
Ok got car back from dealer and they could not find a problem with a road test or on the machine, they did say maybe it has to develop into a bigger problem or until a warning light comes on.
I DO MISS MY BERLINGO Heart
Reply
#5
(16-09-2011, 09:03 AM)philip Wrote:  Ok got car back from dealer and they could not find a problem with a road test or on the machine, they did say maybe it has to develop into a bigger problem or until a warning light comes on.
How's the car now ?- I hope the blingo's loss of power problems disappeared
Former 2011 Mk3 XTR owner Confusedalut:
Reply
#6
Nope still loosing power from time to time.


Sent from my iPhone using Tapatalk
I DO MISS MY BERLINGO Heart
Reply
#7
Hi Philip.
Try to change petrol station.
Reply
#8
DAft reply, TBH but when you are moving, and its safe to try this, press the footbrake slightly together with the Accel pedal, and see if you loose power, I believe that when you press the foot brake it slightly kills power to the engine, had this problem on an 53 plate Xara Pic exclusive (cruise control fitted) there was 2x micro switches on the pedal on that model., just for your info as that was my problem a few years back..
Reply
#9
(18-11-2011, 09:06 PM)pk7478 Wrote:  Hi Philip.
Try to change petrol station.
Hmmm never thought of that one, i do normally use either Esso or Morrisons.


(18-11-2011, 10:27 PM)digger Wrote:  DAft reply, TBH but when you are moving, and its safe to try this, press the footbrake slightly together with the Accel pedal, and see if you loose power, I believe that when you press the foot brake it slightly kills power to the engine, had this problem on an 53 plate Xara Pic exclusive (cruise control fitted) there was 2x micro switches on the pedal on that model., just for your info as that was my problem a few years back..
Im not going to know if it looses power because of the micro switches or because i have braked Confusedcratch:

I DO MISS MY BERLINGO Heart
Reply
#10
(19-11-2011, 07:20 AM)philip Wrote:  
(18-11-2011, 09:06 PM)pk7478 Wrote:  Hi Philip.
Try to change petrol station.
Hmmm never thought of that one, i do normally use either Esso or Morrisons.

In fact it's a good idea. Several years ago when I used a petrol from BP, i was tire to replace spark plugs every 3000-4000 km. After changing a petrol station everything become ok.

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
THE ITALIAN BOX ?
Last Post: THE BADGE
Today 09:29 PM
» Replies: 5
» Views: 365
My new partner (well it’s the same van!)
Last Post: Trevor
Today 09:17 PM
» Replies: 3
» Views: 99
new vehicle
Last Post: Javier_432
Today 08:56 PM
» Replies: 8
» Views: 2784
How Often Does AC Need Re-Gassing?
Last Post: hawaiianblue
Today 06:44 PM
» Replies: 16
» Views: 1185
Peugeot partner 09 1.6hdi 75bhp
Last Post: dumdum
Today 05:58 PM
» Replies: 0
» Views: 87
Hi from the Midlands UK
Last Post: dumdum
Today 04:57 PM
» Replies: 3
» Views: 471
Lowering fun
Last Post: dumdum
Today 04:54 PM
» Replies: 10
» Views: 1163
Full 1.9D Van Spares
Last Post: TONX
Today 04:33 PM
» Replies: 0
» Views: 100
Major investment time.
Last Post: malgpz900
Today 12:04 PM
» Replies: 24
» Views: 3563
berlingo clutch pedal play
Last Post: cancunia
Today 09:02 AM
» Replies: 23
» Views: 19700

[-]
Recent Visitors
Locations of visitors to this page