Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hi from Wiltshire
#1
Hi, new user from wilts, have a 2003 berlingo HDi which i love
very high mileage BUT speedo/milometer not working
pod was changed from another vehicle and showed the milage on that to be 236,000
the pod from mine worked in the other vehicle it went into

speedo sensor changed (twice)

auto electrician spent considerable time with no luck- check wiring said was ok
checked pod and said that was ok
so baffled- said the BSI had lost part comunication- so i purchased a used ECU/BSI/Lock barrel from a running vehicle
swapped that all over, started fine showed mileage(did not increase when driven up road) from that ECU but still no speedo!!!

PLEASE HELP am totally baffled.. reinstalled original BSI/ECU Angry 

central locking works (only on key- not remote, changed battery) is this possibly related?

had a mate bring diagnostic gear but he found that the computer said no, said on screen this vehicle is not OBD2 compatible

checked at citroen build date was 6/3/2003
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Central locking problem
Last Post: Art b
Today 09:55 AM
» Replies: 4
» Views: 265
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Today 09:25 AM
» Replies: 13
» Views: 7481
Headlight adjustment
Last Post: ffrenchie
Today 07:14 AM
» Replies: 1
» Views: 185
Windscreen Arm Linkage keeps Popping Off
Last Post: polar
Today 05:05 AM
» Replies: 6
» Views: 231
2004 alternator not charging
Last Post: Art b
Yesterday 10:06 PM
» Replies: 2
» Views: 292
NEW USER ELIANO, NEEDS HELP ON GENERAL CHAT
Last Post: Gadgetman
Yesterday 09:20 PM
» Replies: 11
» Views: 4450
Another Newbie
Last Post: geoff
Yesterday 08:21 PM
» Replies: 3
» Views: 198
AUX install for radio
Last Post: Matija Danko
Yesterday 06:37 PM
» Replies: 2
» Views: 390
handbrake travel and wheels fitment
Last Post: jj9
Yesterday 06:09 PM
» Replies: 8
» Views: 1054
Alternator not charging no 12v at small purple w...
Last Post: Art b
Yesterday 01:30 PM
» Replies: 4
» Views: 13527

[-]
Recent Visitors
Locations of visitors to this page