Thread Rating:
  • 20 Vote(s) - 3.6 Average
  • 1
  • 2
  • 3
  • 4
  • 5
battery light on at stand still and off when driving
#1
can any shed any light on the reason for the battery light to be on when at stand still and goes of when driving, i have tested the battery to see if there is a charge from the alternator and everything seem fine so im a little bemused Confused
oh i have a 2004 berling 1.9 d lx
Reply
#2
It's a charging light. Mine will remain on at start up until the throttle is 'blipped' and then it goes out and remains out.
If that light should come on when driving it indicates a problem with the charging system (alternator/voltage regulator)
but not necessarily a poor battery, for instance a battery that cannot hold charge due internal problems would
probably not show up.
The Older I get the Better I Was!  Cool
Reply
#3
when i rev the van at stand still the light stays on it only goes out when driving.
Reply
#4
it might be worth checking the electrolyte level of the battery it may need topping up with distilled water (it slops around when driving)
Reply
#5
(16-09-2011, 02:50 PM)zed35467 Wrote:  when i rev the van at stand still the light stays on it only goes out when driving.
I think that is worth getting checked out by an auto electrician or at least a phone call to a trustworthy repairer.
I've not heard of that particular problem before and unless the BSI is telling fibs it sounds very strange. Confusedcratch:

The Older I get the Better I Was!  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 10:49 PM
» Replies: 687
» Views: 151126
One brake light working
Last Post: dumdum
Yesterday 11:36 AM
» Replies: 11
» Views: 946
Rear Hub Nut Size
Last Post: ntm1275
24-03-2019 11:06 PM
» Replies: 4
» Views: 929
Engine noise
Last Post: cancunia
24-03-2019 05:01 PM
» Replies: 31
» Views: 14502
Cruise control (again), yes again, but working (...
Last Post: cancunia
23-03-2019 01:24 PM
» Replies: 101
» Views: 15744
2003 2.0 HDI Poor fuel consumption
Last Post: Trevor
23-03-2019 12:38 PM
» Replies: 34
» Views: 10359
puff of blue-ish smoke on startup
Last Post: Art b
22-03-2019 10:37 PM
» Replies: 12
» Views: 1506
Speedo / Instrument Cluster Removal
Last Post: cancunia
22-03-2019 04:05 PM
» Replies: 2
» Views: 400
airbag stolen - is it a thing
Last Post: rapidyellow
22-03-2019 10:39 AM
» Replies: 3
» Views: 837
EGR valve
Last Post: cancunia
22-03-2019 10:19 AM
» Replies: 1
» Views: 224

[-]
Recent Visitors
Locations of visitors to this page