Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] Temperature gauge shoots up to high, and STOP warning signal on dashboard display
#1
Hi just bought a 2004 Berlingo 1.4 petrol. Driving it back from the car dealer, it drove fine, no problems at all, the temp gauge was a steady 70-80 degrees, however after about 30 minutes of driving the temp gauge shot up almost instantly, and the STOP warning signal came on. I stopped fearing the worst (head gasket etc.). After opening the bonnet the radiator fan kicked in, after about 10 minutes I checked the water, and the tank seemed fairly full. I re-started the car and the temp gauge stayed at 70 - 80 degrees, I drove for another 20 minutes to get home, and I left the engine on for another 15 minutes to try and replicate the STOP warning, but the temperature stayed steady around 90 degrees. the car seemed to drive OK throughout, though I think I could smell a faint smell of coolant steam - though couldn't see any obvious leaks. 

I've read on forums that this warning could be due to the thermostat, or a temp sensor.

I'm thinking of taking it back to the dealer to get it checked/fixed but before I do I'd like to know what it possibly could be and what the best/likely remedies might be.

1. What's the best way of replicating this fault - I guess more driving to see when it happens again, but presumably if I leave the car running stationary for 30 minutes or so it should happen again?

2. To be sure of rectifying the fault, what should be replaced/be done to make sure its gone?

Any thoughts/help gladly received!
Reply
#2
I'm going to guess at the thermostat sticking. Once it opened it worked, but while it was stuck things boiled. It's the only logical explanation really.
Running the engine up from cold on your driveway might cause it to happen again. Think i'd be buying a new one as it's cheap peace of mind anyway
Fire bad, tree pretty
Reply
#3
(20-02-2016, 09:00 PM)Kez Wrote:  I'm going to guess at the thermostat sticking. Once it opened it worked, but while it was stuck things boiled. It's the only logical explanation really.
Running the engine up from cold on your driveway might cause it to happen again. Think i'd be buying a new one as it's cheap peace of mind anyway

Thanks Kez, will try this route to fix it, so presumably the water may have actually got hot caused by the thermostat, would that explain the smell of coolant steam?
Reply
#4
Ring the dealer you bought it from and tell him what happened. If he is reputable he should fix it for you. It could have been an airlock which has worked it's way out of the system and not need anything but it's wise to check it out.
So where does this bit go then ?
[-] The following 1 user says Thank You to ffrenchie for this post:
  • ron
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Parts identification help please!!
Last Post: Huddo
Today 11:06 AM
» Replies: 0
» Views: 17
Replacing Ignition switch / barrel
Last Post: ffrenchie
Today 08:56 AM
» Replies: 19
» Views: 17217
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 08:33 AM
» Replies: 479
» Views: 79262
Airbag light suprise
Last Post: cancunia
Today 07:58 AM
» Replies: 8
» Views: 610
Berlingo over reving when changing gear
Last Post: polar
Yesterday 05:36 PM
» Replies: 4
» Views: 352
Berlingo Head Unit Saga Continues?
Last Post: Argos69
Yesterday 12:02 PM
» Replies: 5
» Views: 682
ABS Light
Last Post: cancunia
Yesterday 08:06 AM
» Replies: 20
» Views: 3434
2004 gearbox removal difficulty...
Last Post: Art b
19-10-2018 09:09 PM
» Replies: 5
» Views: 655
Inherited Volvo - sell to put towards a Berlingo...
Last Post: brodfather11
19-10-2018 07:48 PM
» Replies: 4
» Views: 590
injectors wjy 1.9d
Last Post: jj9
19-10-2018 01:10 PM
» Replies: 9
» Views: 948

[-]
Recent Visitors
Locations of visitors to this page