Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] Temperature gauge shoots up to high, and STOP warning signal on dashboard display
#1
Hi just bought a 2004 Berlingo 1.4 petrol. Driving it back from the car dealer, it drove fine, no problems at all, the temp gauge was a steady 70-80 degrees, however after about 30 minutes of driving the temp gauge shot up almost instantly, and the STOP warning signal came on. I stopped fearing the worst (head gasket etc.). After opening the bonnet the radiator fan kicked in, after about 10 minutes I checked the water, and the tank seemed fairly full. I re-started the car and the temp gauge stayed at 70 - 80 degrees, I drove for another 20 minutes to get home, and I left the engine on for another 15 minutes to try and replicate the STOP warning, but the temperature stayed steady around 90 degrees. the car seemed to drive OK throughout, though I think I could smell a faint smell of coolant steam - though couldn't see any obvious leaks. 

I've read on forums that this warning could be due to the thermostat, or a temp sensor.

I'm thinking of taking it back to the dealer to get it checked/fixed but before I do I'd like to know what it possibly could be and what the best/likely remedies might be.

1. What's the best way of replicating this fault - I guess more driving to see when it happens again, but presumably if I leave the car running stationary for 30 minutes or so it should happen again?

2. To be sure of rectifying the fault, what should be replaced/be done to make sure its gone?

Any thoughts/help gladly received!
Reply
#2
I'm going to guess at the thermostat sticking. Once it opened it worked, but while it was stuck things boiled. It's the only logical explanation really.
Running the engine up from cold on your driveway might cause it to happen again. Think i'd be buying a new one as it's cheap peace of mind anyway
Fire bad, tree pretty
Reply
#3
(20-02-2016, 09:00 PM)Kez Wrote:  I'm going to guess at the thermostat sticking. Once it opened it worked, but while it was stuck things boiled. It's the only logical explanation really.
Running the engine up from cold on your driveway might cause it to happen again. Think i'd be buying a new one as it's cheap peace of mind anyway

Thanks Kez, will try this route to fix it, so presumably the water may have actually got hot caused by the thermostat, would that explain the smell of coolant steam?
Reply
#4
Ring the dealer you bought it from and tell him what happened. If he is reputable he should fix it for you. It could have been an airlock which has worked it's way out of the system and not need anything but it's wise to check it out.
So where does this bit go then ?
[-] The following 1 user says Thank You to ffrenchie for this post:
  • ron
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
DRLs
Last Post: Tree
Yesterday 09:20 PM
» Replies: 1
» Views: 69
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 09:07 PM
» Replies: 787
» Views: 205457
Chinese diesel heater.
Last Post: jtr rhyl
Yesterday 08:08 PM
» Replies: 5
» Views: 633
Tyres and wheel sizes
Last Post: Pdamo
Yesterday 04:00 PM
» Replies: 2
» Views: 597
Another air con problem
Last Post: Peter Palmer
Yesterday 02:31 PM
» Replies: 24
» Views: 5639
From van to 2 birth micro camper
Last Post: Little boy blue
Yesterday 09:56 AM
» Replies: 8
» Views: 1624
New Berlingo Ordered
Last Post: chrisl
Yesterday 09:43 AM
» Replies: 5
» Views: 1162
Have I broken my customers bsi? !
Last Post: polar
19-08-2019 09:28 PM
» Replies: 6
» Views: 460
New clutch fitted, now reverse lights not workin...
Last Post: John B
19-08-2019 08:06 PM
» Replies: 2
» Views: 225
Citroen DS3 Alloys
Last Post: Gollycrush
19-08-2019 07:25 PM
» Replies: 7
» Views: 3898

[-]
Recent Visitors
Locations of visitors to this page