Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electrical Issue (Partner)
#1
Hi,

I have a 2003 1.9 Partner and recently the battery light has started to come on whilst driving (not all the time tho), sometimes it just turns off again but it always turns off when the engine is restarted.

I have checked the voltage whilst idling/revving and all appears ok which leads me to believe the alternator is fine. The van has never had an issue starting tho.

There is a single small wire which goes onto the alternator (guessing for the sensor) and this seemed pretty corroded so replaced the connector but this doesn't seem to have made any difference.

There are a couple of other issues but I not sure if they are related or not, the horn only works with the ignition off and when the battery light comes on the stereo (aftermarket) switches off.

The rest of the electrics appear fine tho!

If anyone has any ideas I would be grateful.
Reply
#2
Hi burtross your horn issue is probably the earth on the steering wheel under the airbag. Ive had to do both of my berlingos to sort it. There is a thread on here with pictures to show you how to do it have a search. Here you go http://www.berlingoforum.co.uk/thread-36...l#pid26651 have a look at post 12. Thanks to Geoff for the post. As for the other faults start with the basics check battery is good and good connections, same with alternator check contacts/wiring and output. You should be getting about 14 volts when engine running Check earth leads from battery and engine to chassis.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 10:13 PM
» Replies: 355
» Views: 45480
Clutch cable mounting plate?
Last Post: geoff
Yesterday 09:49 PM
» Replies: 4
» Views: 420
1.6 hdi lumpy cold start
Last Post: Zion
Yesterday 09:28 PM
» Replies: 52
» Views: 6687
Bypass heater matrix?
Last Post: Zion
Yesterday 09:11 PM
» Replies: 3
» Views: 592
Radio wiring.
Last Post: Zion
Yesterday 09:07 PM
» Replies: 11
» Views: 1519
newbie
Last Post: weldore
Yesterday 08:00 PM
» Replies: 2
» Views: 168
Peugeot partner 2.0 hdi 90, will a 406 2.0 hdi 1...
Last Post: Civvic
Yesterday 02:40 PM
» Replies: 1
» Views: 396
FOR SALE Amdro Bootjump £1100
Last Post: Elbie
Yesterday 01:11 PM
» Replies: 0
» Views: 158
Dingo - 05 - 2.0 HDI
Last Post: coakers
Yesterday 10:13 AM
» Replies: 80
» Views: 16889
Panoramic sunroof (+2008) model for weekend camp...
Last Post: Elbie
Yesterday 10:02 AM
» Replies: 5
» Views: 717

[-]
Recent Visitors
Locations of visitors to this page