sluggish
#1
Have an 04, 2.0 hdi with 45000 on the clock. Recently it's been a bit sluggish so I replaced the fuel filter housing. Took it for a test drive it was fine. Next time it was started up, it was back to it's old sluggish self. Sat in neutral i can't get it to rev past 2750 rpm. No warning lights are lit. Any ideas or can anyone recommend a good garage in the Sunderland area. Thought I'd found one but he turned out to be a tosser. TIA
Reply
#2
"Sat in neutral i can't get it to rev past 2750 rpm." - What about driving? Can you get over 55mph? If not, sounds like you have gone into limp/safe mode. There are many reasons why this might be. You will need to get the fault codes read and these will indicate where the problem lie. Trying to diagnose problems without these codes is difficult, at best, and could lead to unnecessary expense. Every garage should have a code reader and be able to tell you what's wrong
Reply
#3
i had the same thing,no engine light warning but it was in limp mode....it was the egr solenoid,the valve under the airfilter box with 2 black air pipes coming from it.one goes to egr valve other goes to vacuum pump.but without code reader as already said in previous post its guesswork
Reply
#4
Thanks to you both. Have previously had a warning light which was apparently egr valve related. Had removed valve for cleaning but it didn't seem too bad.
Is there any way to test the solenoid myself? TIA
Reply
#5
Disconnected the battery for 30 mins and then went for a spin. No problems, running like a dream. Let's hope it stays that way.
Reply
#6
hope it stays that way, mine was intermitant,so i took it to pieces,there is not a lot you can do but after removing the bottom you will see an allen key screw i turned it fully anti-clockwise and put it back.no problem since and the car is a flyer now.the solenoid that is not egr valve sorry!
Reply




Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search








(Advanced Search)

[-]
Latest Threads
Dingo - 05 - 2.0 HDI
Last Post: Grizz
Today 05:42 PM
» Replies: 23
» Views: 2983
post screen blacked out
Last Post: geoff
Today 05:24 PM
» Replies: 49
» Views: 6170
Led Lights
Last Post: tomhick024
Today 04:39 PM
» Replies: 4
» Views: 291
Cold start and low revs issue
Last Post: KenZzx
Today 02:19 PM
» Replies: 3
» Views: 124
I'm getting alloys - but what?
Last Post: doofer
Today 01:55 PM
» Replies: 2
» Views: 87
Insurance advice after crash
Last Post: Gravity
Today 01:26 PM
» Replies: 4
» Views: 529
Berlingo Miltispace XTR (2008)
Last Post: squiddley
Today 10:28 AM
» Replies: 0
» Views: 79
DESPERATE WITH MY BERLINGO DESIRE 2.0 HDI 2004 ...
Last Post: cancunia
Today 07:01 AM
» Replies: 13
» Views: 1585
After filling up with fuel.
Last Post: doofer
Today 06:41 AM
» Replies: 5
» Views: 519
Battery occasionally totally drains overnight
Last Post: waggoner
Yesterday 11:42 PM
» Replies: 9
» Views: 797

[-]
Recent Visitors
Locations of visitors to this page