Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
had new radiator fit now no power :s
#1
so I had a new radiator fit and seem to have no power when driving I don't know anything about cars but the pipe on pics had come off front grill will this make a difference [Image: 562898d4e090e199fe8a3655477f057e.jpg][Image: 69fca000b898c6f5c3fa19366174caf5.jpg]

Sent from my SM-G920F using Tapatalk
Reply
#2
The pipe is for a cold air feed in to the air filter the engine work's better with cold air if the engine is taking in warm / hot air from the engine bay call heat soak it will not run so efficiently but only by a small amount refit the pipe see how you get on.
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#3
attached it no loo. garage has just said seems like head gasket or injector!!!

Sent from my SM-G920F using Tapatalk
Reply
#4
More info needed here ...............

Was the vehicle running well / normally before the new radiator was fitted ?

Why did you have a new rad fitted ? leaking ? engine over heating ? other reason ?
Reply
#5
radiator was leaking iv had it sorted now was a loose connection or something and got it back and now starter motor has gone. no look with this van at all

Sent from my SM-G920F using Tapatalk
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Central locking problem
Last Post: Art b
Today 09:55 AM
» Replies: 4
» Views: 265
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Today 09:25 AM
» Replies: 13
» Views: 7481
Headlight adjustment
Last Post: ffrenchie
Today 07:14 AM
» Replies: 1
» Views: 185
Windscreen Arm Linkage keeps Popping Off
Last Post: polar
Today 05:05 AM
» Replies: 6
» Views: 232
2004 alternator not charging
Last Post: Art b
Yesterday 10:06 PM
» Replies: 2
» Views: 292
NEW USER ELIANO, NEEDS HELP ON GENERAL CHAT
Last Post: Gadgetman
Yesterday 09:20 PM
» Replies: 11
» Views: 4450
Another Newbie
Last Post: geoff
Yesterday 08:21 PM
» Replies: 3
» Views: 198
AUX install for radio
Last Post: Matija Danko
Yesterday 06:37 PM
» Replies: 2
» Views: 390
handbrake travel and wheels fitment
Last Post: jj9
Yesterday 06:09 PM
» Replies: 8
» Views: 1054
Alternator not charging no 12v at small purple w...
Last Post: Art b
Yesterday 01:30 PM
» Replies: 4
» Views: 13527

[-]
Recent Visitors
Locations of visitors to this page