Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Airbag light question by complete novice
#1
Afternoon. I have the airbag light issue, which seems fairly common. It comes on with a beep then another beep seconds later. The issue 'fixed' itself for a week or so, then came back

Could someone please steer in in the right direction with the easiest options to try first. Consider me technically-challenged when answering, and please outline the steps I need to take in each possible solution. Don't assume knowledge on my part when it coma to naming components

Many thanks

Marco
Reply
#2
First thing have you been moving the seats back and forward lately? if so check the connectors under the seats as they play up. Plenty of threads on the site if you have a search.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#3
Make sure nothing is trapped or lodged under the seat. Any debris under there and mine comes on.
Try the seat in different positions while the engine is off to see if it goes out when you start her up.
Gives the connectors under the seat a squirt with WD or some GT85
Reply
#4
There are normally two connectors under the seat [one brown, one white] one is for the seat belt warning and the other for the airbag warning system. Normally it is one of those. You can try pulling them apart and cleaning, note that electrical contact cleaner is a better choice than WD40 or such, as contact cleaner evaporates completely rather than WD40 type sprays that leave a "thin film" on the contacts which can cause problems over time.

Also make sure the wires are secure in the connectors, they are prone to pulling out due to rear passengers feet kicking them.
[-] The following 1 user says Thank You to Multispacer for this post:
  • Chris Baker
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 10:13 PM
» Replies: 355
» Views: 45480
Clutch cable mounting plate?
Last Post: geoff
Yesterday 09:49 PM
» Replies: 4
» Views: 420
1.6 hdi lumpy cold start
Last Post: Zion
Yesterday 09:28 PM
» Replies: 52
» Views: 6687
Bypass heater matrix?
Last Post: Zion
Yesterday 09:11 PM
» Replies: 3
» Views: 592
Radio wiring.
Last Post: Zion
Yesterday 09:07 PM
» Replies: 11
» Views: 1519
newbie
Last Post: weldore
Yesterday 08:00 PM
» Replies: 2
» Views: 168
Peugeot partner 2.0 hdi 90, will a 406 2.0 hdi 1...
Last Post: Civvic
Yesterday 02:40 PM
» Replies: 1
» Views: 396
FOR SALE Amdro Bootjump £1100
Last Post: Elbie
Yesterday 01:11 PM
» Replies: 0
» Views: 158
Dingo - 05 - 2.0 HDI
Last Post: coakers
Yesterday 10:13 AM
» Replies: 80
» Views: 16889
Panoramic sunroof (+2008) model for weekend camp...
Last Post: Elbie
Yesterday 10:02 AM
» Replies: 5
» Views: 717

[-]
Recent Visitors
Locations of visitors to this page