Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need some help ASAP
#1
Hello everyone I am new to this site so please bare with me. 

I have a 1999 1.9 dev and it has a few faults. I am pretty hand with cars ect but these have amazed me . The first of is the electrics the heater blower dosnt work at all only very slight and the 12v dosnt work either. Went through the interior fuse box and fount around 7 fuses not live replaced them and still nothing. For some reason there's no power going to some fuses. Any help with these please?  

Many thanks 
Simon
Reply
#2
Do the wipers, lights and horn work and is the heater blower receiving power to work "very slight" ? By "the 12v" do you mean the accessory socket ? Does your car have fuses under the bonnet as well as the ones next to the steering column under the plastic cover ?
So where does this bit go then ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Tyres and suspension
Last Post: Mr Keef
Today 10:42 AM
» Replies: 8
» Views: 700
2007 1.6hdi desire
Last Post: Rob.nixon
Today 10:32 AM
» Replies: 4
» Views: 278
Seats
Last Post: kbracingdk
Yesterday 08:57 PM
» Replies: 0
» Views: 203
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 05:43 PM
» Replies: 630
» Views: 124420
Torsion bar
Last Post: jj9
Yesterday 05:18 PM
» Replies: 8
» Views: 318
Idle speed.
Last Post: polar
Yesterday 05:10 PM
» Replies: 1
» Views: 288
A week has passed.
Last Post: Ikanpaul
Yesterday 12:26 PM
» Replies: 0
» Views: 281
New Berlingo Anyone????
Last Post: Tree
Yesterday 12:21 PM
» Replies: 4
» Views: 516
FK Lowering kit actual drop
Last Post: Matt Haigh
18-01-2019 05:05 PM
» Replies: 6
» Views: 1003
My new partner (well it’s the same van!)
Last Post: dumdum
18-01-2019 04:05 PM
» Replies: 4
» Views: 678

[-]
Recent Visitors
Locations of visitors to this page