Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine resurrection issues
#1
Hi Folks,

I've just replaced the engine in my 2001/2002  Berlingo 2.0hdi dw10. 
Its not starting! 
I'm not too good at diagnosing issues unfortunately.


The engine is turning over.
The glowplug light isnt coming on.
The fuel pump on both engines is the same.
Does my ecu speak to the new injectors/rail?
do i need to re-initialise the ecu.
does the new fuel pump work
have i connected the loom correctly.  
Ive checked the earths.

Any tips would be gratefully received.

Thanks Smile
Reply
#2
Is the equipment the same on new engine (ie injectors)
[-] The following 1 user says Thank You to Col for this post:
  • tortoise365
Reply
#3
You have to change BSI from donor car to yours also.

You probably have immobilizator issue.

It would be a lot easier if you have some diagnostic equipment.

Best regards,
brajomobil
[-] The following 1 user says Thank You to brajomobil for this post:
  • tortoise365
Reply
#4
Hi Thanks for the info,

I dont have the donor bsi! I have ordered diagnostic equipment!

I'll let you know how i get on,

Thanks,
Reply
#5
(05-05-2016, 09:52 AM)tortoise365 Wrote:  Hi Thanks for the info,

I dont have the donor bsi!  I have ordered diagnostic equipment!

I'll let you know how i get on,

Thanks,

Then you can do IMMO off on that engine ECU or install original BSI to
match original ECU. Without that engine will not start.

Best regards,
brajomobil
[-] The following 1 user says Thank You to brajomobil for this post:
  • tortoise365
Reply
#6
(04-05-2016, 12:56 PM)Col Wrote:  Is the equipment the same on new engine (ie injectors)

Good Point! 
 the Old engine has siemens injectors, rail and pump,

The new engine has siemens injectors, bosch rail and the pump has no sticker but looks the same as the old one.

I just want to avoid having to take the injection system apart. cos the haynes says you've got to buy new pipes if you do this. and keep everything clean! 

Thanks again!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Corrosion on a B9?
Last Post: jj9
Today 12:21 AM
» Replies: 9
» Views: 739
Cheap Berlingo Multi space
Last Post: jj9
Yesterday 11:30 PM
» Replies: 4
» Views: 165
1.6HDi - acceptable play on turbo shaft?
Last Post: jj9
Yesterday 11:21 PM
» Replies: 2
» Views: 129
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:20 PM
» Replies: 416
» Views: 64071
Berlingo 1.6 hdi bad knocking/tapping
Last Post: V6BOY
Yesterday 07:52 PM
» Replies: 10
» Views: 495
Rear wiper working from indicator stalk
Last Post: Peter Palmer
Yesterday 07:32 PM
» Replies: 1
» Views: 258
Recommend Socket Set
Last Post: evdama
Yesterday 10:40 AM
» Replies: 6
» Views: 961
Indicator keeps blinking
Last Post: evdama
Yesterday 10:37 AM
» Replies: 1
» Views: 253
Old member returning
Last Post: ffrenchie
Yesterday 06:56 AM
» Replies: 2
» Views: 283
Wiring Diagram Berlingo M59
Last Post: Zion
Yesterday 05:25 AM
» Replies: 1
» Views: 265

[-]
Recent Visitors
Locations of visitors to this page