Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] flashing battery light
#1
2003 berlingo multispace forte 1.6 petrol manual-----does anyone know or had the battery warning and centre display and interior lights flash on and off after engine switched off and keys out of ignition? there was also a clicking noise near the ignition barrel area. took my car to garage fault hasn't come up when I dropped the car off (sod's law!) garage plugged in diagnostics reader no faults apart from headlight minor fault. anyone got any suggestions first time on here so any help would be very much appreciated

thanks
Reply
#2
Sorry but the only time my interior lights flashed on/off was when I had not shut a door properly.
--------------------------------------------------------------

2012 Iron Grey XTR 110 with lots of bits and bobs.
[-] The following 1 user says Thank You to Trevor for this post:
  • Tristan Mead
Reply
#3
Have you checked the alternator?

I had the battery light on my 1.6 petrol when it was failing.
[-] The following 1 user says Thank You to tucker for this post:
  • Tristan Mead
Reply
#4
Did the garage do a battery/alternator check and BSI reset first?
Reply
#5
(25-05-2016, 06:15 AM)Hi thanks, will check with the garage but the problem seems to be very unpredictable as the fault stopp  ed when I dropped the car off, so I guess it\s hard to know what Wrote:  Did the garage do a battery/alternator check and BSI reset first?
Reply
#6
(24-05-2016, 02:01 PM)Tristan Mead Wrote:  2003 berlingo multispace forte 1.6 petrol manual-----does anyone know or had the battery warning and centre display and interior lights flash on and off after engine switched off and keys out of ignition? there was also a clicking noise near the ignition barrel area. took my car to garage fault hasn't come up when I dropped the car off (sod's law!) garage plugged in diagnostics reader no faults apart from headlight minor fault. anyone got any suggestions first time on here so any help would be very much appreciated

thanks

Hello Tristan and everybody else!

I'm new to this Forum. I've just bought my second Berlingo - a 2004 2.0 HDI and I'm very happy with it, apart from when I first got it a couple of days ago, I had exactly the same problem as you have described above - when I have finished driving it and turn the ignition off and take the key out of the ignition, the battery warning light has been flashing and the internal lights and digital display on the dashboard have been flashing, along with a strange clicking noise.

However, touch wood, it does seem to have stopped doing it now after a couple more days of driving it around. I'm hoping that maybe the battery was just a bit flat when I first bought it and now that it's charged up a bit after being driven around, it's working as normal. Fingers crossed!

Or, is this a common problem which others have had too?

Cheers!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: jj9
Today 09:58 PM
» Replies: 353
» Views: 44855
Front end vibration
Last Post: kingy1912
Today 09:20 PM
» Replies: 8
» Views: 1078
Engine Fault Light Error Code P1434
Last Post: Lighty
Today 08:54 PM
» Replies: 7
» Views: 539
Radio wiring.
Last Post: Zion
Today 06:56 PM
» Replies: 9
» Views: 1196
Eurotunnel Height Restrictions
Last Post: geoff
Today 11:27 AM
» Replies: 9
» Views: 696
ENGINE WONT START WHEN HOT
Last Post: dan.wfs
Today 11:25 AM
» Replies: 7
» Views: 758
Panoramic sunroof (+2008) model for weekend camp...
Last Post: kazza
Today 08:54 AM
» Replies: 4
» Views: 522
More power
Last Post: polar
Today 08:02 AM
» Replies: 1
» Views: 267
Amdro Boot Jump for sale, £1400
Last Post: Gravity
Today 05:52 AM
» Replies: 3
» Views: 508
1.6 hdi lumpy cold start
Last Post: Zion
Yesterday 09:04 PM
» Replies: 50
» Views: 6435

[-]
Recent Visitors
Locations of visitors to this page