Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
hello all!! help please!!
#1
So its a 2001 hdi peugeot partner which is basically a berlingo, but..... i unplugged the instument cluster on sat to run wires for bluetooth mic. But i stupidly did it out disconnecting the battery, now all the instruments still work but the lcd milage and clock display is blank!!! Help!!!
Reply
#2
Are the fuses ok? . I think the clock is fused but could be any fuse , check them all.
Reply
#3
Thanks for reply, yup all fuses ok so far Sad
Reply
#4
Try a BSI reset first just google BSI reset for info
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Multispace xtr rear door moulding trim need
Last Post: photosavage
Today 11:36 AM
» Replies: 4
» Views: 375
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: jj9
Today 09:23 AM
» Replies: 348
» Views: 43691
1.6 hdi lumpy cold start
Last Post: jj9
Today 09:20 AM
» Replies: 41
» Views: 4877
Peugeot partner 2.0 hdi 90, will a 406 2.0 hdi 1...
Last Post: wuppertdupont
Today 12:51 AM
» Replies: 0
» Views: 127
Hello! Shwmae!
Last Post: Satellitemark
Yesterday 08:11 PM
» Replies: 3
» Views: 400
EML strangeness
Last Post: johnnyb
Yesterday 07:59 PM
» Replies: 11
» Views: 1734
Greetings from an old new boy
Last Post: Tomcat3
Yesterday 04:49 PM
» Replies: 2
» Views: 217
Tow bar and electrics
Last Post: Cuthbert
Yesterday 04:29 PM
» Replies: 3
» Views: 714
Bypass heater matrix?
Last Post: Normg002
17-06-2018 08:36 PM
» Replies: 0
» Views: 338
Service light and other strange things happen
Last Post: Zion
17-06-2018 07:28 PM
» Replies: 1
» Views: 468

[-]
Recent Visitors
Locations of visitors to this page