Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Odometer fine but no speedo.
#1
Hi, 

1. Month ago I had some Type of sheet metal wrapped around the timing belt pullies which I removers. Not sure if the metal came of the van or picked up from the road. There has been a whirring noise ever since, not a problem but may be relevant to the problem. 

2. The odometer displays but the speedo fails after the engine starts to warm up and the mileage doesn't change when the speedo dial fails. If I co 70mph+ the whole of the dials/warning light/odometer display goes blank. 

3. Acceleration is a little abrupt when accelerating from low revs. This has become noticeable since the timing pully problem. 

I'm thinking there may be some kind of sensor for the speedo I could check? Or the local wiring to it? Where would I find it?

Any ideas?

Thanks Lee.
Reply
#2
you may want to try change this,not expensive from Citroen,easy diy fit if you can get underneath,just up the rear of the gearbox,mine went,same symptoms with the clock plus sometimes it didn't seem to have the turbo,other times it was fine,changed it and all back to normal,mines a 1.6hdi van on a 58 plate.

[Image: a%20switch_zpshoinrepm.jpg]
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
Reply
#3
Thanks Ian, any idea what the part is called?

Mines a 55 plate 2L HDI on 170000 miles. Do you think the part will be in the same place?

Lee.
Reply
#4
it will be in that area yes,but looking on ebay it's a slightly different shape on the 2ltr, it's the speed sensor, sends signals to the clocks and ecu ( the ecu bit i didn't realise,but it could explain the performance some time).. hope it clears it up for you,I'll watch this space..Ian.
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
Reply
#5
Top man, I'll get to the motor factors. 

Lee.
Reply
#6
Let's us know if it sorts it out,always like to know if the problem gets solved,cheers
Reply
#7
(06-06-2016, 01:28 PM)Totsy Wrote:  Top man, I'll get to the motor factors. 

Lee.

I had to visit the stealers for mine,wasn't bad actually haha
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
Reply
#8
Will do Johny555. I've ordered the part from eBay. The motor factors don't sell them, said I'd need to go to Citroen. I think it was £11. Try and replace it this week. 

Lee.
Reply
#9
Well got the part but the only wire and plug I can see anywhere on the gearbox is at the rear between the box and the bulkhead with a three pin plug attached. The part I have is completely different to the sensor the plug fits onto on the car other than they are all three pin plugs/sockets. I've taken a picture I'll try and post it. 

Lee.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
injectors wjy 1.9d
Last Post: split rivet
Today 10:36 AM
» Replies: 8
» Views: 577
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 09:17 AM
» Replies: 473
» Views: 77940
2018 Berlingo....
Last Post: msw109
Yesterday 11:47 PM
» Replies: 9
» Views: 1795
2004 gearbox removal difficulty...
Last Post: jj9
Yesterday 10:00 PM
» Replies: 3
» Views: 265
Inherited Volvo - sell to put towards a Berlingo...
Last Post: geoff
Yesterday 08:37 PM
» Replies: 2
» Views: 226
Replacing Ignition switch / barrel
Last Post: drc200
Yesterday 04:10 PM
» Replies: 18
» Views: 16901
Alarm wiring connections
Last Post: drc200
Yesterday 02:55 PM
» Replies: 0
» Views: 201
New in a Berlingo that need a new injection pump...
Last Post: swedish
Yesterday 10:52 AM
» Replies: 5
» Views: 637
Eberspacher or similar
Last Post: hawaiianblue
Yesterday 01:20 AM
» Replies: 8
» Views: 1743
New windscreen
Last Post: Hardnut
17-10-2018 08:49 PM
» Replies: 3
» Views: 409

[-]
Recent Visitors
Locations of visitors to this page