Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ECU And BSI swap
#1
Hi Guys, I have recently bought a 2003 berlingo van. 1.9 D. Engine code WJY.
I had a problem with the  MOT, as the STOP light on the dash would not go off and constantly beeped. The fuel gauge also didnt work and wipers were a bit dodgy. I had a auto electrician out to the van and he diagnosed the ECU & BSI unit was faulty.These were replaced along with the ignition barrel and key. it all seems to have solved the problems with the electrical things that were faulty, but the van will not start now, it turns over, and sounds like it wants to start but it will not fire.I have been told that there is a coded valve or something simular on the fuel pump !!!!
I would really like to know any ideas or knowledge any body has on this subject, as i need the van for work and its just sat on my drive with no MOT or tax(SORN) i cant move it to take it to a garage because it has no tax and i cant take it for an MOT because it wont start AAAGHHHH  !!!!!!!
Please help.
Cheers Guys many thanks in advance for help.
JOHN
Reply
#2
(06-06-2016, 08:23 PM)Reedy Wrote:  Hi Guys, I have recently bought a 2003 berlingo van. 1.9 D. Engine code WJY.
I had a problem with the  MOT, as the STOP light on the dash would not go off and constantly beeped. The fuel gauge also didnt work and wipers were a bit dodgy. I had a auto electrician out to the van and he diagnosed the ECU & BSI unit was faulty.These were replaced along with the ignition barrel and key. it all seems to have solved the problems with the electrical things that were faulty, but the van will not start now, it turns over, and sounds like it wants to start but it will not fire.I have been told that there is a coded valve or something simular on the fuel pump !!!!
I would really like to know any ideas or knowledge any body has on this subject, as i need the van for work and its just sat on my drive with no MOT or tax(SORN) i cant move it to take it to a garage because it has no tax and i cant take it for an MOT because it wont start AAAGHHHH  !!!!!!!
Please help.
Cheers Guys many thanks in advance for help.
JOHN

Hi John. Try taking out the shunt fuse in the fuse box ( large grey fuse with sh on 1 side and f's on the other) this resets the BSI unit. Leave out for 15 minutes and then put it back ).   Hope this helps.... Mary
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Parts identification help please!!
Last Post: Huddo
Today 11:06 AM
» Replies: 0
» Views: 17
Replacing Ignition switch / barrel
Last Post: ffrenchie
Today 08:56 AM
» Replies: 19
» Views: 17217
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 08:33 AM
» Replies: 479
» Views: 79262
Airbag light suprise
Last Post: cancunia
Today 07:58 AM
» Replies: 8
» Views: 610
Berlingo over reving when changing gear
Last Post: polar
Yesterday 05:36 PM
» Replies: 4
» Views: 352
Berlingo Head Unit Saga Continues?
Last Post: Argos69
Yesterday 12:02 PM
» Replies: 5
» Views: 682
ABS Light
Last Post: cancunia
Yesterday 08:06 AM
» Replies: 20
» Views: 3434
2004 gearbox removal difficulty...
Last Post: Art b
19-10-2018 09:09 PM
» Replies: 5
» Views: 655
Inherited Volvo - sell to put towards a Berlingo...
Last Post: brodfather11
19-10-2018 07:48 PM
» Replies: 4
» Views: 590
injectors wjy 1.9d
Last Post: jj9
19-10-2018 01:10 PM
» Replies: 9
» Views: 948

[-]
Recent Visitors
Locations of visitors to this page