Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ECU And BSI swap
#1
Hi Guys, I have recently bought a 2003 berlingo van. 1.9 D. Engine code WJY.
I had a problem with the  MOT, as the STOP light on the dash would not go off and constantly beeped. The fuel gauge also didnt work and wipers were a bit dodgy. I had a auto electrician out to the van and he diagnosed the ECU & BSI unit was faulty.These were replaced along with the ignition barrel and key. it all seems to have solved the problems with the electrical things that were faulty, but the van will not start now, it turns over, and sounds like it wants to start but it will not fire.I have been told that there is a coded valve or something simular on the fuel pump !!!!
I would really like to know any ideas or knowledge any body has on this subject, as i need the van for work and its just sat on my drive with no MOT or tax(SORN) i cant move it to take it to a garage because it has no tax and i cant take it for an MOT because it wont start AAAGHHHH  !!!!!!!
Please help.
Cheers Guys many thanks in advance for help.
JOHN
Reply
#2
(06-06-2016, 08:23 PM)Reedy Wrote:  Hi Guys, I have recently bought a 2003 berlingo van. 1.9 D. Engine code WJY.
I had a problem with the  MOT, as the STOP light on the dash would not go off and constantly beeped. The fuel gauge also didnt work and wipers were a bit dodgy. I had a auto electrician out to the van and he diagnosed the ECU & BSI unit was faulty.These were replaced along with the ignition barrel and key. it all seems to have solved the problems with the electrical things that were faulty, but the van will not start now, it turns over, and sounds like it wants to start but it will not fire.I have been told that there is a coded valve or something simular on the fuel pump !!!!
I would really like to know any ideas or knowledge any body has on this subject, as i need the van for work and its just sat on my drive with no MOT or tax(SORN) i cant move it to take it to a garage because it has no tax and i cant take it for an MOT because it wont start AAAGHHHH  !!!!!!!
Please help.
Cheers Guys many thanks in advance for help.
JOHN

Hi John. Try taking out the shunt fuse in the fuse box ( large grey fuse with sh on 1 side and f's on the other) this resets the BSI unit. Leave out for 15 minutes and then put it back ).   Hope this helps.... Mary
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Corrosion on a B9?
Last Post: jj9
Today 12:21 AM
» Replies: 9
» Views: 739
Cheap Berlingo Multi space
Last Post: jj9
Yesterday 11:30 PM
» Replies: 4
» Views: 165
1.6HDi - acceptable play on turbo shaft?
Last Post: jj9
Yesterday 11:21 PM
» Replies: 2
» Views: 129
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:20 PM
» Replies: 416
» Views: 64071
Berlingo 1.6 hdi bad knocking/tapping
Last Post: V6BOY
Yesterday 07:52 PM
» Replies: 10
» Views: 495
Rear wiper working from indicator stalk
Last Post: Peter Palmer
Yesterday 07:32 PM
» Replies: 1
» Views: 258
Recommend Socket Set
Last Post: evdama
Yesterday 10:40 AM
» Replies: 6
» Views: 961
Indicator keeps blinking
Last Post: evdama
Yesterday 10:37 AM
» Replies: 1
» Views: 253
Old member returning
Last Post: ffrenchie
Yesterday 06:56 AM
» Replies: 2
» Views: 283
Wiring Diagram Berlingo M59
Last Post: Zion
Yesterday 05:25 AM
» Replies: 1
» Views: 265

[-]
Recent Visitors
Locations of visitors to this page