Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Multispace rear blower
#1
Hi guys, the blowers in the rear do not work, it's an m59, is there a common fuse that blows here?

Thanks in advance
Reply
#2
Andi I may not be much help but just to let you know, when I had the Berlingo Desire modutop the blower for the rear passengers also did not work. When I investigated this problem ages ago I came across a thread where someone had isolated the problem to the blower inside the modutop. Had to take the modutop mostly down to reach it and something was reconnected if I remember rightly. Try various searches in the mean time.
2012(62) XTR 1.6 92bhp Airdream Modutop
Reply
#3
A few searches turned this up for reading http://www.berlingoforum.co.uk/thread-9595-page-3.html
2012(62) XTR 1.6 92bhp Airdream Modutop
Reply
#4
Excellent, maplins here I come. Well tomorrow anyway
Reply
#5
Parts bought, job for tomorrow
Reply
#6
Thanks for the help guys, thermal fuse replaced as per that guide, very easy to do and a quick .99p outlay
Reply
#7
Congratulations on fixing that blower Andy. Was it as straight forward as that thread looks or can you offer any more tips?
2012(62) XTR 1.6 92bhp Airdream Modutop
Reply
#8
Really straight forward, whilst in maplins buy x2 uninsulated terminals, I had to shave the plastic off the ones I had, but it is very straight forward, if you had to buy the terminals then it would be a job for under £1.50!

Go for it, it's easy
Reply
#9
(22-06-2016, 10:30 PM)Andi DK Wrote:  Really straight forward, whilst in maplins buy x2 uninsulated terminals, I had to shave the plastic off the ones I had, but it is very straight forward, if you had to buy the terminals then it would be a job for under £1.50!

Go for it, it's easy

Good stuff
I asked for / on behalf of anyone else with this problem really, I no longer have the mark 2 / b59 Berlingo.
2012(62) XTR 1.6 92bhp Airdream Modutop
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Corrosion on a B9?
Last Post: jj9
Today 09:18 PM
» Replies: 3
» Views: 83
Cranks won't start no smoke
Last Post: brodfather11
Today 09:05 PM
» Replies: 1
» Views: 46
I love my Berlingo
Last Post: Zweli
Today 07:57 PM
» Replies: 3
» Views: 419
Oil on top of engine
Last Post: Gravity
Today 05:16 PM
» Replies: 7
» Views: 430
timing belt failure
Last Post: Tree
Today 02:25 PM
» Replies: 9
» Views: 947
Berlingo electrical woes
Last Post: Eddie78
Today 11:07 AM
» Replies: 12
» Views: 1193
Mirrorlink Update May Be On The Way!
Last Post: lingolady
Today 08:51 AM
» Replies: 23
» Views: 11957
Not a Berlingo but its the same Chassis....
Last Post: Tree
Yesterday 03:36 PM
» Replies: 1
» Views: 570
2007 Peugeot Partner Escapade 1.6Hdi
Last Post: cancunia
Yesterday 02:35 PM
» Replies: 2
» Views: 259
New engine old pump
Last Post: polar
Yesterday 02:29 PM
» Replies: 6
» Views: 719

[-]
Recent Visitors
Locations of visitors to this page