Thread Rating:
  • 8 Vote(s) - 2.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Heater "valve" problem
#1
My friend has a 2002 2L HDI Mulitspace (Canbus wiring).

After a two week break, he started the car and drove a few miles and then got a nasty hot electrical smell.

Looking under the bonnet, the alternator was red hot and smoking heavily. The alternator was indeed dead (stator windings cooked) and was replaced with a pukka Valeo 150 amp unit.

The 8 year old battery, though able to start the car reliably, was also replaced with a new one.

But the hot alternator problem remained so he checked around with a meter and found that the new alt was continuously pumping out 80A even once the car was warm with no other loads on.

Looking around he spotted a unit in the heater matrix hose fed by massive cables and found that it was live all the time, drawing a constant load of about 70amps. (RH end of the engine – looking at it – under the intake ducting, below and behind the battery tray). There is no mention of this unit in the Haynes manual or in the wiring diagram.

He’s now disconnected it, the heavy alternator load has gone (6amps now after a few minutes at tickover) and the car seems to be fine. The heater still works as it did originally.

He’s bought a second-hand one off Ebay – called a heater valve – pictured here (from a 2.0HDi Xantia).

   

Its clearly not a “valve” but appears to be a cluster of glowplugs. We can only assume this a “quick de-frost” device and that the control circuit or relay for this has gone U/S. Presumably it should switch off once the coolant is warm. The vehicle is still running perfectly with this part disconnected.

We hope this helps some else.
'98 D 800 van Big Grin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Knocking noise over bumps
Last Post: TioPotz
Today 05:44 PM
» Replies: 4
» Views: 594
Heavy steering feel 2.0 HDi 2005
Last Post: big_chris88
Today 05:34 PM
» Replies: 2
» Views: 243
Cambelt?
Last Post: geoff
Today 03:11 PM
» Replies: 4
» Views: 541
B9 Camper Build with Step by Step Photos
Last Post: MrDrizz
Today 12:28 PM
» Replies: 54
» Views: 13063
Rebuilt the suspension - clunks and groans!
Last Post: GraemeT
Today 11:48 AM
» Replies: 0
» Views: 99
1.6 hdi lumpy cold start - SOLVED!
Last Post: cancunia
Today 09:16 AM
» Replies: 91
» Views: 14068
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Tomcat3
Today 06:50 AM
» Replies: 383
» Views: 54159
Mirrorlink Update May Be On The Way!
Last Post: Tree
Yesterday 08:47 PM
» Replies: 18
» Views: 9655
DIY Berlingo Day Van/Occasional Camper System [P...
Last Post: Trevor
Yesterday 06:59 PM
» Replies: 3
» Views: 276
Wireless charger.
Last Post: bluesmartie
Yesterday 06:27 PM
» Replies: 12
» Views: 810

[-]
Recent Visitors
Locations of visitors to this page