Thread Rating:
  • 8 Vote(s) - 2.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Heater "valve" problem
#1
My friend has a 2002 2L HDI Mulitspace (Canbus wiring).

After a two week break, he started the car and drove a few miles and then got a nasty hot electrical smell.

Looking under the bonnet, the alternator was red hot and smoking heavily. The alternator was indeed dead (stator windings cooked) and was replaced with a pukka Valeo 150 amp unit.

The 8 year old battery, though able to start the car reliably, was also replaced with a new one.

But the hot alternator problem remained so he checked around with a meter and found that the new alt was continuously pumping out 80A even once the car was warm with no other loads on.

Looking around he spotted a unit in the heater matrix hose fed by massive cables and found that it was live all the time, drawing a constant load of about 70amps. (RH end of the engine – looking at it – under the intake ducting, below and behind the battery tray). There is no mention of this unit in the Haynes manual or in the wiring diagram.

He’s now disconnected it, the heavy alternator load has gone (6amps now after a few minutes at tickover) and the car seems to be fine. The heater still works as it did originally.

He’s bought a second-hand one off Ebay – called a heater valve – pictured here (from a 2.0HDi Xantia).

   

Its clearly not a “valve” but appears to be a cluster of glowplugs. We can only assume this a “quick de-frost” device and that the control circuit or relay for this has gone U/S. Presumably it should switch off once the coolant is warm. The vehicle is still running perfectly with this part disconnected.

We hope this helps some else.
'98 D 800 van Big Grin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Snow Tyres
Last Post: Gollycrush
Yesterday 09:32 PM
» Replies: 0
» Views: 118
EML light on - No Fault Code
Last Post: TONX
Yesterday 08:05 PM
» Replies: 0
» Views: 138
No Click from Solenoid
Last Post: Zweli
Yesterday 07:46 PM
» Replies: 0
» Views: 125
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Yesterday 07:11 PM
» Replies: 24
» Views: 8805
What website to pass time over a winters evening...
Last Post: josegar
Yesterday 05:05 PM
» Replies: 5
» Views: 2644
Headlight adjustment
Last Post: Sophiante
Yesterday 05:02 PM
» Replies: 2
» Views: 562
Hi from a me and what to do.
Last Post: cancunia
Yesterday 04:49 PM
» Replies: 3
» Views: 273
2004 alternator not charging
Last Post: Art b
Yesterday 10:58 AM
» Replies: 3
» Views: 611
AUX install for radio
Last Post: ntm1275
22-09-2018 10:17 PM
» Replies: 3
» Views: 797
Lowering springs
Last Post: DMaclean
22-09-2018 07:28 PM
» Replies: 0
» Views: 329

[-]
Recent Visitors
Locations of visitors to this page