Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Oil Leak xtr
#1
Berlingo multispace xtr 2009. 
Bought 4 months ago. 

I have a minor oil leak one drop per max per night. 
Black regular smelling oil coming from my engine.
I have possible traced the oils back to a few locations. 
What do ye think is this a common leak. 
Images attached.


Attached Files Thumbnail(s)
   
Reply
#2
Image 2


Attached Files Thumbnail(s)
   
Reply
#3
Image 3


Attached Files Thumbnail(s)
   
Reply
#4
It looks like it is coming from the turbo oil feed pipe...the big hexagonal screw in the first picture...maybe you could see if it is loose and tighten it, or, if not loose, clean/change the joint and set the screw with correct torque settings...
Reply
#5
That's been leaking for some time so may not be as bad as it looks. Oil will spread around a lot in the air flow.
I would use a degreaser and wash it all away until clean and dry, you should then easily see where the problem lies.

The air outlet from the turbo has an O ring which often fails and results in oil around the same area.
[-] The following 1 user says Thank You to Solent for this post:
  • BerlingoMultifault
Reply
#6
If you clean off the oil you should be able to locate leak. If it is from turbo oil feed pipe I would get it looked at soonest.
[-] The following 1 user says Thank You to Opensauce for this post:
  • BerlingoMultifault
Reply
#7
If you look at image 3, you'll see that the oil filter housing cap is broken, the edge is split, I'd be replacing this before going any further, a lot of the staining will be historic from oil changes.
[-] The following 1 user says Thank You to Macca79 for this post:
  • BerlingoMultifault
Reply
#8
I am not sure that an oil leak from the filter would spill oil upwards as high as you see in picture 1...
Reply
#9
(22-06-2016, 05:02 AM)Luis Rosa Wrote:  It looks like it is coming from the turbo oil feed pipe...the big hexagonal screw in the first picture...maybe you could see if it is loose and tighten it, or, if not loose, clean/change the joint and set the screw with correct torque settings...

Hi Luis Rosa. 
Thank you. It does look like it's coming from the oil feed pipe. 
I hate saying this but the turbo was replaced (first time, gauze removed) a few months ago and my be loose since then.

I'll tighten it clean up the area, change the oil and keep my fingers crossed. 
Thanks again.
Reply
#10
(22-06-2016, 08:54 AM)Macca79 Wrote:  If you look at image 3, you'll see that the oil filter housing cap is broken, the edge is split, I'd be replacing this before going any further, a lot of the staining will be historic from oil changes.

Hi Macca79. 
Funny I'm looking at the real thing and never noticed it. Thanks for pointing it out.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Greetings from an old new new boy
Last Post: tonyt
Today 02:52 PM
» Replies: 0
» Views: 11
1.6 hdi lumpy cold start
Last Post: jj9
Today 01:56 PM
» Replies: 39
» Views: 4391
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 08:52 AM
» Replies: 343
» Views: 43096
Bypass heater matrix?
Last Post: Normg002
Yesterday 08:36 PM
» Replies: 0
» Views: 190
Service light and other strange things happen
Last Post: Zion
Yesterday 07:28 PM
» Replies: 1
» Views: 419
Gearbox replacement
Last Post: Zion
Yesterday 07:17 PM
» Replies: 1
» Views: 338
ENGINE WONT START WHEN HOT
Last Post: geoff
Yesterday 03:51 PM
» Replies: 3
» Views: 408
Multispace xtr rear door moulding trim need
Last Post: gazthelad
Yesterday 11:37 AM
» Replies: 1
» Views: 205
Replacement Seat Back Trays?
Last Post: Gravity
Yesterday 06:14 AM
» Replies: 1
» Views: 332
Hello! Shwmae!
Last Post: 3rensho
Yesterday 05:51 AM
» Replies: 2
» Views: 264

[-]
Recent Visitors
Locations of visitors to this page