Thread Rating:
  • 7 Vote(s) - 3.29 Average
  • 1
  • 2
  • 3
  • 4
  • 5
engine light
#1
Exclamation 
The yellow engine light is staying on. It's a 1.6hdi, nothing seems out of the ordinary. Economy might be slightly down. Any ideas? What does this light cover?
Reply
#2
Didn't go out to check mine but might it be that a service is due soon?
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#3
Nope 10k left to service and that's for 15k intervals not 20k
Reply
#4
Needs a diagnostic or coupling to a code reader to give you a clue otherwise you might as well urinate in the prevailing wind...
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
[-] The following 1 user says Thank You to andy-womble for this post:
  • pk7478
Reply
#5
Went away for 2 days then came back this morning. Went to limp mode until I reset.
Reply
#6
Got it read. It's low fuel rail pressure.

So first thing replace the fuel filter.

Reply
#7
changed the fuel filter, dead easy starts straight away.
hope that solves it
Reply
#8
(31-10-2011, 04:16 PM)corkgsxr Wrote:  changed the fuel filter, dead easy starts straight away.
hope that solves it

When did you last change it? Fuel filters should be changed every major service iirc.
Want Help with the Forum? Read Help Documents Here

Reply
#9
Never did. Ment to have been done before I bought it and id do it every second service. Iv only one service done so it was to be next one.

Hasn't went to limp mode yet so I do hope that was it
Reply
#10
(31-10-2011, 08:18 PM)corkgsxr Wrote:  Never did. Ment to have been done before I bought it and id do it every second service. Iv only one service done so it was to be next one.

Hasn't went to limp mode yet so I do hope that was it

Fingers crossed for you. Was the fuel filter a simple in out job? Our engine management light has been on for a while now, and its starting to not like starting up/revs drop till stall sometimes. I thought it was the cat at first, obviously not...
Want Help with the Forum? Read Help Documents Here

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Juddering when pulling away
Last Post: brodfather11
Today 08:02 AM
» Replies: 17
» Views: 2293
Crankcase pressure reference values?
Last Post: saskak
Today 07:32 AM
» Replies: 4
» Views: 279
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Tomcat3
Today 07:22 AM
» Replies: 708
» Views: 161505
Replacement TPS Sensor
Last Post: jimbo
Yesterday 10:34 PM
» Replies: 10
» Views: 890
Powerflex Front Anti Roll Bar Bushes
Last Post: NANO_Vigo
Yesterday 08:52 PM
» Replies: 0
» Views: 138
new member needing lots of help
Last Post: cancunia
Yesterday 05:44 PM
» Replies: 12
» Views: 1586
2.0 hdi abs no communication from abs ecu
Last Post: cancunia
Yesterday 04:48 PM
» Replies: 5
» Views: 489
B9 Head Unit Upgrade
Last Post: dumdum
Yesterday 03:56 PM
» Replies: 2
» Views: 455
Longshot... dash pics required
Last Post: dumdum
Yesterday 03:47 PM
» Replies: 0
» Views: 193
Titsup
Last Post: Martinez
Yesterday 12:55 PM
» Replies: 16
» Views: 2991

[-]
Recent Visitors
Locations of visitors to this page