Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
persistent injector problems
#1
good morning all.
I need your help! My diesel has 230,000 miles and has been maintained from new to a high standard.
Recently, it started with injector failure. First one was replaced. Then shortly after, a second failed, so all were replaced with reconditioned. Within a thousand miles, one of these failed. This was replaced.  Now, another has failed twice in the hundred miles and my mechanic is scratching his head....any ideas what could cause this persistent failure? I've been told possible fuel pump, grinding it's self up and clogging the injectors? This is now costing me serious money, so just want to sort it. Thanks in advance! Chris
Reply
#2
It does stand a chance its fuel pump problems.

You dont say which engine you have?

If its a 1.6hdi i would break open the fuel filter and check for particles with a magnet - If it is the fuel pump you will also need to drain and clean out the fuel tank after you have replaced the pump.
Reply
#3
Hi Polar,

Yes it's the 1.6 hdi. You mirror what has been suggested to me already, so I think this is the way forward...unless antone else has further thoughts, all are appreciated.
Reply
#4
This sometimes happens on diesels that had petrol in a few months earlier
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Recommend Socket Set
Last Post: evdama
Today 10:40 AM
» Replies: 6
» Views: 797
Indicator keeps blinking
Last Post: evdama
Today 10:37 AM
» Replies: 1
» Views: 154
Berlingo 1.6 hdi bad knocking/tapping
Last Post: polar
Today 10:28 AM
» Replies: 6
» Views: 219
Old member returning
Last Post: ffrenchie
Today 06:56 AM
» Replies: 2
» Views: 184
Wiring Diagram Berlingo M59
Last Post: Zion
Today 05:25 AM
» Replies: 1
» Views: 177
Cranks won't start no smoke
Last Post: Zweli
Yesterday 07:02 PM
» Replies: 2
» Views: 419
Corrosion on a B9?
Last Post: V6BOY
Yesterday 04:22 PM
» Replies: 7
» Views: 550
boot/trunk light not working
Last Post: densortefane
Yesterday 02:57 PM
» Replies: 1
» Views: 247
Stereo/CD up-grade?
Last Post: Sumo278
Yesterday 01:28 PM
» Replies: 2
» Views: 707
Coolant leak from back of engine
Last Post: Gadgetman
Yesterday 01:18 PM
» Replies: 10
» Views: 1478

[-]
Recent Visitors
Locations of visitors to this page