Thread Rating:
  • 15 Vote(s) - 3.13 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Key fob doesnt unlock central locking
#1
Hi, I have a 1998 Berlingo. I have a niggly problem with my keyfob. Mabye somebody knows how to sort this out.

I got a 2nd hand ignition as the old one was worn with a new key. I replaced the electronics board and the chip inside the new key with the board and chip from the old key. This works fine. The immobilser accepts the new key ( and new ignition).

The problem with the electroncis board is that the button that activates the locking mechanism was worn. I replaced that with a new button that I soldered on. This seems to work as each time I press the onbaord LED light activates.

However, the locking mechanism is not responding.

Does anyone know if this scenario requires reprogramming of the chip or the electronics board and where can you get this done for how much approximately?

I have investigated and some sites talk about reprogramming for the immobiliser. However, the replacement key works fine with my immobiliser but NOT with the central locking.

The user-manual also mentions that in order to re-link the key to the immobiliser after batteries have been replaced it must be placed into the ignition the motor should be started and then the button must be pressed. I did all that but the central locking still doesn't respond.

There are two possible scenarios i can see here:
I might have Physcially damaged the board while soldering ( but I don't know how to chekc for that ) or the integrated chips require some form of resetting after the heat from the soldering iron.

any advice appreciated. It would stop me from messing around with two keys.
Reply
#2
I hope that you used a gas soldering iron!
The reason is that the residual ripple current in the tip of a mains iron is enough to damage any chip nearby the component that you've soldered in if you didn't unplug it before you used it on the board.
Hopefully this isn't the case and the BSI just needs re-programming/ resetting. If the vehicle that you got the board from didn't have central locking it may be that it just needs activating via Lexia. HTH :thumbsup:
The Older I get the Better I Was!  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Number plate lights staying on.
Last Post: Gordon Taylor
Today 08:45 PM
» Replies: 4
» Views: 189
handbrake travel and wheels fitment
Last Post: rapidyellow
Today 07:13 PM
» Replies: 2
» Views: 372
2016 berlingo 1.6 hdi oil change time
Last Post: jj9
Today 06:26 PM
» Replies: 27
» Views: 2187
P0115 fault
Last Post: Dizzydave
Today 03:42 PM
» Replies: 0
» Views: 88
berlingo clutch pedal play
Last Post: cancunia
Today 01:01 PM
» Replies: 19
» Views: 15234
Old member returning
Last Post: Yorkshire Bling
Today 10:53 AM
» Replies: 3
» Views: 421
Just bought a 1.6HDi - a few questions
Last Post: cancunia
Today 07:03 AM
» Replies: 3
» Views: 308
Dip beam level adjustment motor
Last Post: Blackshuck
Today 05:55 AM
» Replies: 3
» Views: 554
where did they go ?
Last Post: ajcommercial
Yesterday 11:06 PM
» Replies: 8
» Views: 810
Random beep
Last Post: ajcommercial
Yesterday 10:39 PM
» Replies: 4
» Views: 627

[-]
Recent Visitors
Locations of visitors to this page