Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.6 hdi issues
#1
Hi, I picked up my second berlingo 1.6 hdi this time a 75 model.
62k on the clock, 07 plate.

After driving it for a couple of days I've noticed that the turbo makes a high pitched whistle like noise, however the turbo is new as it is immaculate and the garage I bought it from said it was new. (Reputable garage)

It also has a really hesitant and juddery acceleration. It only happens in 4th and 5th gear and only ever does it if you put your foot down. You can change in to either 4th or 5th early at low revs and put your foot down and it won't do it.

I've adjusted the brake pedal switch as I read somewhere that apparently this can cause it. But that hasn't worked.

No fault codes are showing up, no warning loghts on the dash etc.

What could it possibly be?

Worst case, injector maybe? But surely this would be constant throughout every gear as I've had injectors go in my trafic van once.

Egr? Could it be possibly stuck open/closed

Throttle position sensor? (If it has one)

Are the throttles fly by wire? Could this be faulty.

It is extremely annoying! Any help and suggestions would be greatly received.

Cheers

Steve
Reply
#2
Take it back to them to fix it
Reply
#3
Just got off the phone to them. It's going in tomorrow morning
Reply
#4
Sounds like they may have either just replaced the turbo or used a second hand one.

If you don't replace all the oil feed pipes you have invalidated any warranty on the turbo

I agree with above poster

Take it back, ASAP
Silver Berlingo Multispace 1.4i Forte

Reply
#5
There is a brand new oil feed pipe on there and they told me they even changed that little gauze type filter thing.

After further inspection one of the injectors is covered in thick black sticky mess all around the seal, that is until it cools then it becomes rock solid. My bet is the injector seal has gone causing a misfire.

It's going back in at 8am tomorrow anyway so I'll let you know what the outcome is
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 08:21 PM
» Replies: 356
» Views: 45905
Camper Cushion Fabric
Last Post: Tomcat3
Today 08:01 PM
» Replies: 1
» Views: 32
Radio wiring.
Last Post: Zion
Today 04:42 PM
» Replies: 13
» Views: 1893
That question again
Last Post: jj9
Today 09:40 AM
» Replies: 1
» Views: 186
Clutch cable mounting plate?
Last Post: cancunia
Today 07:31 AM
» Replies: 6
» Views: 631
Missing posts
Last Post: brodfather11
Today 06:05 AM
» Replies: 1
» Views: 312
Dingo - 05 - 2.0 HDI
Last Post: Hardnut
Today 03:49 AM
» Replies: 81
» Views: 17361
1.6 hdi lumpy cold start
Last Post: Zion
Yesterday 09:28 PM
» Replies: 52
» Views: 7138
Bypass heater matrix?
Last Post: Zion
Yesterday 09:11 PM
» Replies: 3
» Views: 713
newbie
Last Post: weldore
Yesterday 08:00 PM
» Replies: 2
» Views: 296

[-]
Recent Visitors
Locations of visitors to this page