Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Steering grinding when full lock or going slow and turning left
#1
Hi my berlingo 1.6 diesel is making a grinding noise when in full lock or when going slow. This is far worse when left turning. The van steers ok but the grinding can be quite loud from inside. The garage had a very quick look this morning but not on the ramp. He said he dosnt think it's the rubbers and mentioned could be the steering rack which I know is pricey. Any ideas as new to this forum cheers.

Sent from my SM-A300FU using Tapatalk
Reply
#2
Check the driveshafts as well ... oh and welcome !
[-] The following 1 user says Thank You to geoff for this post:
  • strepcil
Reply
#3
The bloke I bought car off has just had a quick listen and is adamant the steering rack won't be damaged. He seems to think could be the suspension bushes under bonnet. It's not knocking at all so am hoping it won't be anything to serious. Thanks for reply

Sent from my SM-A300FU using Tapatalk
Reply
#4
Does it make the noise only when you're turning the steering wheel, or does the noise happen when the steering wheel is still and the car is moving?
[-] The following 1 user says Thank You to cancunia for this post:
  • strepcil
Reply
#5
(15-09-2016, 10:51 AM)cancunia Wrote:  Does it make the noise only when you're turning the steering wheel, or does the noise happen when the steering wheel is still and the car is moving?
Hi it's just when turning. Mostly when been turned to the left but also slightly to the right. When moving at speeds this sound hardly appears but loads worse when going slow around sharper corners. When it kicks in I can stop the car and you can hear it stationary when slight turns on the steering wheel. When I start car in morning it won't happen until I have drove around a few corners then the grinding groan sound comes back as normal. Cheers

Sent from my SM-A300FU using Tapatalk
Reply
#6
If it only happens when you turn the wheel, chances are that the bearing at the top between the spring cap and the suspension strut have seized or failed. This happened on my Volvo. Not sure how common it is on the Berlingo though.

Here's a nice picture in flebay

http://www.ebay.co.uk/itm/Citroen-Peugeo...SwQJhUjb69
[-] The following 1 user says Thank You to cancunia for this post:
  • strepcil
Reply
#7
(15-09-2016, 11:58 AM)cancunia Wrote:  If it only happens when you turn the wheel, chances are that the bearing at the top between the spring cap and the suspension strut have seized or failed. This happened on my Volvo. Not sure how common it is on the Berlingo though.

Here's a nice picture in flebay

http://www.ebay.co.uk/itm/Citroen-Peugeo...SwQJhUjb69

yes,I've seen them pop up in threads pretty often,sure someone else will be along to confirm...good luck :-)
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
[-] The following 1 user says Thank You to ians_lingo for this post:
  • strepcil
Reply
#8
Thanks

Sent from my SM-A300FU using Tapatalk
Reply
#9
hi strepcil, i had similar prob on my lingo, i changed lower suspension arms, noise gone now ,dont know if this info will help you, regards GWYN
Big Grin nice to be important,more important to be nice Wink
Reply
#10
Thanks bud apreciate advice. Fingers crossed not to much to worry about then. Cheers

Sent from my SM-A300FU using Tapatalk
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
That question again
Last Post: Luis Rosa
Today 04:55 AM
» Replies: 4
» Views: 308
Newbie from Tyne and Wear
Last Post: 3rensho
Today 02:42 AM
» Replies: 1
» Views: 79
Tailgate Tent for Berlingo. New. Only £70.
Last Post: YorkieDave
Yesterday 10:59 PM
» Replies: 4
» Views: 1150
1.6 HDI 90 clutch replacement, poss. single mass...
Last Post: jj9
Yesterday 10:19 PM
» Replies: 1
» Views: 118
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 09:50 PM
» Replies: 358
» Views: 46174
1.6 hdi lumpy cold start
Last Post: Zion
Yesterday 09:32 PM
» Replies: 53
» Views: 7413
Camper Cushion Fabric
Last Post: Tomcat3
Yesterday 08:01 PM
» Replies: 1
» Views: 132
Radio wiring.
Last Post: Zion
Yesterday 04:42 PM
» Replies: 13
» Views: 2044
Clutch cable mounting plate?
Last Post: cancunia
Yesterday 07:31 AM
» Replies: 6
» Views: 710
Missing posts
Last Post: brodfather11
Yesterday 06:05 AM
» Replies: 1
» Views: 346

[-]
Recent Visitors
Locations of visitors to this page