Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clock/display
#1
I have a 2014 Enterprise van, and have had a couple of issues with the clock display.
One day it did not light up, and was completely blank. I took it to my nearest dealer (15 miles away) and they sorted it, saying it was a bad connection and it is now fitted as tightly as it can be. It worked for four days.
I am reluctant to take it back, partly due to distance and the difficulty in getting a Saturday appointment, and partly due to lack of confidence in their ability to fix it permanently (on the same visit they diagnosed a faulty ABS light as being due to a dirty sensor, however it turned out that the pick up ring on the offside rear disc had broken away - how they missed that I have no idea)
Anyhow, I have searched the Forum thoroughly and cannot find anyone who has had a similar problem. If it is something as simple as a connection somewhere, can anyone tell me how to go about finding it and what I need to move/remove to get proper access
Many thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Today 06:29 PM
» Replies: 11
» Views: 7184
AUX install for radio
Last Post: Peter Palmer
Today 06:23 PM
» Replies: 1
» Views: 206
Another Newbie
Last Post: Tomcat3
Today 06:15 PM
» Replies: 1
» Views: 17
handbrake travel and wheels fitment
Last Post: jj9
Today 06:09 PM
» Replies: 8
» Views: 917
Windscreen Arm Linkage keeps Popping Off
Last Post: Jayfranco
Today 06:05 PM
» Replies: 2
» Views: 22
Alternator not charging no 12v at small purple w...
Last Post: Art b
Today 01:30 PM
» Replies: 4
» Views: 13426
2004 alternator not charging
Last Post: frank
Today 01:28 PM
» Replies: 1
» Views: 110
NEW USER ELIANO, NEEDS HELP ON GENERAL CHAT
Last Post: Gravity
Today 01:09 PM
» Replies: 10
» Views: 4105
Central locking problem
Last Post: srcomp
Today 12:43 PM
» Replies: 0
» Views: 66
rear axle mot failure
Last Post: jj9
Today 09:51 AM
» Replies: 3
» Views: 421

[-]
Recent Visitors
Locations of visitors to this page