Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Alternator wont charge
#1
So i'm back again with a new problem.. My 1998 berlingo van with the 1.9d engine had a new (used) alternator installed last year after it stopped charging properly. That fixed the problem that time.

A few days ago the battery lamp started coming on again and it stopped charging. The lamp has been coming and going somewhat but mostly it is on and not charging. So I went to get another used alternator supposedly from a very low mileage van. I fitted it like last time and started up but the battery lamp is still there and not charging!

I have tried running wires from alternator ground and battery ground. Also from alternator plus to battery plus. Both to check if a bad connection was the problem. Now I don't know where to go from here. Du you guys have any idea what could be wrong?
Reply
#2
Go get a new alternator,2nd hand is a waste off time mate,,course they will tell its off a low milage van,there not going to say its off a high miler are they,check bottom pully as well ,the belt might be sliping
Reply
#3
It just seems strange with 2 broken alternators. They wouldn't sell me a broken one knowingly as they offer a warranty on the parts. It would be a freak coincidence. Alternators don't break THAT often.

Pulley and belt is ok. Tight and not slipping.
Reply
#4
Best way round it is just get a new one,their not that expensive, and it saves all that messing about,that's just my opinion,
Reply
#5
On an alternator the brushes usually wear out and any other problems sit in the " rare event " category.

Brushes typically come complete with the diode pack rather than separately and I would fit a set to the " new last year " unit and go from there. They are easily fitted, well I think so anyway and not expensive either.

I naturally assume you will check the condition of the commutator before parting with your hard earned .........
Reply
#6
I'm with Jonny on this. Fit new, and you have a proper warranty.
Reply
#7
Thing is.. It,s always in the rare event category when something ia wrong with my cars. It's never what it seems to be Sad


Sent from my iPhone using Tapatalk
Reply
#8
Mighty,

 You said you checked the earth and feed to the battery so assume they are ok.

The light coming on and off may mean a bad connection/broken wire on the small feed wire

  There should be 12 volts with the ignition on at the small terminal at the alternator.
Reply
#9
A good auto electrician can bench test it if you want to prove the alternator is faulty.
Reply
#10
(13-10-2016, 07:24 AM)Col Wrote:  A good auto electrician can bench test it if you want to prove the alternator is faulty.

Very true my local chap will test for free and will supply a new brush / diode pack for either myself or him to fit, typically off the shelf.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
1.6 hdi turbo fail again advice please
Last Post: cancunia
Today 02:49 PM
» Replies: 29
» Views: 4051
Headlights staying on
Last Post: cancunia
Today 12:17 PM
» Replies: 5
» Views: 137
M59 Cruise Control Stalk (not speed limiter)
Last Post: cancunia
Today 12:09 PM
» Replies: 4
» Views: 441
B9 tuning update
Last Post: northroadycles
Today 08:38 AM
» Replies: 0
» Views: 116
Steering wheel?
Last Post: alavya
Today 07:18 AM
» Replies: 3
» Views: 496
Brake switch location on 2013 automatic Partner
Last Post: eSPe
Yesterday 09:26 PM
» Replies: 0
» Views: 226
MY PARROT CAN'T TALK !
Last Post: karma846
Yesterday 08:36 PM
» Replies: 1
» Views: 243
all weather tyres?
Last Post: SayAnything
Yesterday 06:25 PM
» Replies: 9
» Views: 435
I am selling my beloved Berlingo
Last Post: suewills
Yesterday 10:00 AM
» Replies: 4
» Views: 517
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:30 AM
» Replies: 560
» Views: 105341

[-]
Recent Visitors
Locations of visitors to this page